Results 1 to 8 of 8
  1. #1
    Chrisrokc's Avatar
    Join Date
    Apr 2006
    Location
    Oklahoma City, OK
    Posts
    3,667

    Anyone have a messed up EFI controller?

    I think I remember reading someone on here had a busted EFI controller. I think the story went, slow speeds, low rpms, problems. Couldn't figure out why the lose in speed, removed the EFI controller and everything ran a billion time better.

    Anyone?


  2. #2
    MR. SCOVILLE UNIT SUCKMYWAKE's Avatar
    Join Date
    Aug 2005
    Location
    ASTON, PENNSYLVANIA
    Posts
    2,836
    +1
    8
    i know some who have had problems with the ground wire itself.

  3. #3
    KamikazeGPR's Avatar
    Join Date
    Mar 2007
    Location
    Philadelphia
    Posts
    1,361
    +1
    99
    I have seen posts in past where the wires have pulled out of the back of the square connector plug on the efi controller.They look like they're in there until you look closely.

  4. #4
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11
    Quote Originally Posted by SUCKMYWAKE View Post
    i know some who have had problems with the ground wire itself.
    yeah,and its no fun.

  5. #5
    Chrisrokc's Avatar
    Join Date
    Apr 2006
    Location
    Oklahoma City, OK
    Posts
    3,667
    Hmm! What problem does this cause?

    I am trying to find the gremlin in my ski!

  6. #6
    Gatorcountry's Avatar
    Join Date
    Jun 2006
    Location
    Punta Gorda, FL
    Posts
    342
    Mine has a good ground wire - it just quit working. No symptoms, it just doesn't deliver any extra fuel. Nice to find out how lean I've been.

  7. #7
    MR. SCOVILLE UNIT SUCKMYWAKE's Avatar
    Join Date
    Aug 2005
    Location
    ASTON, PENNSYLVANIA
    Posts
    2,836
    +1
    8
    Quote Originally Posted by Chrisrokc View Post
    Hmm! What problem does this cause?

    I am trying to find the gremlin in my ski!

    i can send you my known good one to test if you would like to do that

  8. #8
    Chrisrokc's Avatar
    Join Date
    Apr 2006
    Location
    Oklahoma City, OK
    Posts
    3,667
    Quote Originally Posted by SUCKMYWAKE View Post
    i can send you my known good one to test if you would like to do that
    Yea I might do that, I will check my ground tomorrow and see if it is good. I will shoot you a pm.

    Thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. anyone have instructions for rude fuel controller?
    By dav_dman in forum 4-Tec Performance
    Replies: 4
    Last Post: 03-05-2010, 11:29 AM
  2. WTB anyone have a scratched up rxp hood good for painting?
    By caliburst in forum Sea Doo Classifieds
    Replies: 16
    Last Post: 11-13-2009, 10:34 AM
  3. Anyone have a screwed up fuji case....
    By starflight in forum Polaris Open Discussion
    Replies: 3
    Last Post: 10-28-2008, 04:27 PM
  4. Anyone have an EFI 1300 ported by Lowell
    By Lvnspeed in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 10-04-2006, 10:37 PM
  5. anyone have any close up pics of handlebar extensions??
    By psycho rxp in forum 4-Tec Performance
    Replies: 9
    Last Post: 02-06-2006, 07:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •