Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    02 gtx not getting full rpms

    so after 3 weeks in the shop i get my ski back today. Went in for a cluster code and low rpms. The codes are gone but still only reaching 6500 rpms and 40 on the dash with a 500 lb load. My gut is telling me its the impeller, if it comes out of the water under throttle it shoots to 7200 then right back down after. Dealer states its most likely a fuel issue and dump the tank so i ran it out today, but have a feeling its more than just a water in the fuel issue. Any help is greatly appreciated.


  2. #2
    Ever had the sc rebuilt?

  3. #3
    Quote Originally Posted by VaRedneck View Post
    Ever had the sc rebuilt?

    its not supercharged also it is a little rough at idle

  4. #4
    fuel or plugs

  5. #5
    Bump any idea?

  6. #6
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    fresh gas and fresh plugs!

  7. #7

    Join Date
    Sep 2013
    Location
    FL
    Posts
    118
    +1
    8
    def. start with spark plugs

  8. #8
    Quote Originally Posted by TacomaGuy24 View Post
    def. start with spark plugs
    Changing the plugs today, and starting off with fresh fuel tomorrow let's see if it fixed the problem thanks

  9. #9
    Quote Originally Posted by smartzaps View Post
    Quote Originally Posted by TacomaGuy24 View Post
    def. start with spark plugs
    Changing the plugs today, and starting off with fresh fuel tomorrow let's see if it fixed the problem thanks
    Nee plugs and fuel with the same result. Max rpms at 6500 with a rough idle. It feels like it wants to go but something is holding it back

  10. #10

    Join Date
    Sep 2013
    Location
    FL
    Posts
    118
    +1
    8
    is the oil overfilled maybe?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2015 RXP-X 260 Not getting full RPM?
    By Lstorm2003 in forum 4-Tec Performance
    Replies: 14
    Last Post: 05-31-2016, 06:42 PM
  2. Rxpx 260 14 hrs not getting full rpm?
    By Lstorm2003 in forum 4-Tec Performance
    Replies: 14
    Last Post: 10-05-2015, 06:29 AM
  3. 00 gtx di not reaching full rpm
    By derekshep in forum 2-Stroke Performance
    Replies: 0
    Last Post: 07-26-2013, 09:10 AM
  4. 02 genisis, not getting RPM's & insturment problems
    By robert.c in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 07-21-2010, 11:51 PM
  5. not getting full RPMs
    By sealz in forum 4-Tec Performance
    Replies: 5
    Last Post: 09-26-2008, 03:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •