Results 1 to 2 of 2
  1. #1

    Join Date
    May 2014
    Location
    Paris, TN
    Posts
    23
    +1
    2

    07 GTI se 155 exhaust temp warning

    To start with I'm new to Sea Doo's. I've got a 2007 GTI 155 with 107 hours on it. You can run it for about 5 to 10 minutes then the warning buzzer goes off and it says exhaust temp on the gauge. Any ideas? thanks in advance.


  2. #2

    Join Date
    May 2014
    Location
    Paris, TN
    Posts
    23
    +1
    2
    nevermind everyone, found the problem. I inspected the pump and the housing is cracked where the water line to the exhaust is. I must have sucked up a rock or something.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Are there any aftermarket exhausts for 2015 gti se 155
    By Waterypig in forum 4-Tec Performance
    Replies: 13
    Last Post: 07-31-2015, 07:35 AM
  2. Looking For 07 Gti Se 155 Ecu & wiring & keys
    By JohnnyGtiSe in forum Sea Doo 4Tec Skis
    Replies: 0
    Last Post: 08-05-2009, 01:22 AM
  3. '07 GTI SE 155Hp
    By Bama_007 in forum 4-Tec Performance
    Replies: 9
    Last Post: 05-11-2008, 07:18 AM
  4. Exhaust Temp Warning ?
    By steach in forum Yamaha PWC Performance (2-stroke)
    Replies: 29
    Last Post: 04-09-2007, 12:29 PM
  5. GTI SE 155 vs. STX-15f vs. FX H.O.
    By Bama_007 in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 02-10-2007, 12:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •