Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 34

Thread: Impeller

  1. #1
    spouk3's Avatar
    Join Date
    Mar 2012
    Location
    Montreal, QC, Canada
    Posts
    635
    +1
    30

    Impeller

    Hi guys,

    I have changed my impeller, same water temp was running a 15/20r @8060rpm

    I installed a 15/19r and now it's turning at 8500rpm...

    I don't understand... First, there something grinding when going at low speed and doing hard turn (carbon seal or shaft alignment?)

    Is it possible that it's doing cavitation? 1mm and I turn 500 more rpm...

    I have a 8375 tune, and it's turning way over... I don't go at WOT for a long time... I haven't change the valve retainers...

    Thanks for your help!


  2. #2
    Check to be sure pump seal didn't get pinched throwing off alignment.

  3. #3
    spouk3's Avatar
    Join Date
    Mar 2012
    Location
    Montreal, QC, Canada
    Posts
    635
    +1
    30
    My dealer installed the impeller ... I'm not sure where the pump seal is... Let me check in the shop manual.

  4. +1 by:


  5. #4
    ATNryan's Avatar
    Join Date
    Apr 2012
    Location
    River Crew CT
    Posts
    695
    +1
    75
    Did you make sure both props were measured before? My 15/20R was really a 15/19 straight from RIVA. Just because it is stamped one way doesnt mean that it is the actual pitch.

  6. +1 by:


  7. #5
    spouk3's Avatar
    Join Date
    Mar 2012
    Location
    Montreal, QC, Canada
    Posts
    635
    +1
    30
    To be honest... No... This lead me to another question... Running a couple seconds over 8375 rpm on the stock retainers... Is it bad... A couple second I mean like 5 or 10 seconds...

    I plan to do the retainers at the end of the summer... I'm not always at WOT... Normally cruising around 4500-5000...

  8. #6
    NateRXP's Avatar
    Join Date
    May 2013
    Location
    Richmond, TX
    Posts
    746
    +1
    180
    I would also like to know ^^. I plan to run 8200-8375rpm range once prop dialed in on stock valve train. Is it safe? Old threads show 8400+

  9. #7
    spouk3's Avatar
    Join Date
    Mar 2012
    Location
    Montreal, QC, Canada
    Posts
    635
    +1
    30
    @Green Hulk I would love to have your input on this one! Thanks!

  10. #8
    ATNryan's Avatar
    Join Date
    Apr 2012
    Location
    River Crew CT
    Posts
    695
    +1
    75
    Quote Originally Posted by VXRslayer21 View Post
    I would also like to know ^^. I plan to run 8200-8375rpm range once prop dialed in on stock valve train. Is it safe? Old threads show 8400+
    I ran the stock valvetrain at 8350 for an entire season and put 67 hours on it. Never had any issues. Every ski is different, but I would say that you would be safe.

  11. +1 by:


  12. #9
    spouk3's Avatar
    Join Date
    Mar 2012
    Location
    Montreal, QC, Canada
    Posts
    635
    +1
    30
    My question was more... Is it safe to run over 8375rpm for a couple seconds...

    My other question is that I switch from a 15/20r to a 15/19r and I jump about 600rpm... From 7900 to 8500... Is it normal to gain that much or there's something wrong with something else... A seal or something else... I check my wear ring and it's perfect... I don't understand... I taught 2 500rpm more but not 600...

  13. #10

    Join Date
    Aug 2010
    Location
    Massachusetts
    Posts
    225
    +1
    12
    I bet that the 15/20r was not all 20's on the trailing edge...

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What pitch impeller
    By Turbo Todd in forum 4-Tec Performance
    Replies: 10
    Last Post: 11-21-2008, 10:55 AM
  2. which compressor impeller ?
    By eyaliz in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-12-2005, 09:21 AM
  3. Supercharger Impeller Install
    By Teflon in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-09-2005, 06:01 PM
  4. Replies: 3
    Last Post: 05-06-2005, 02:01 PM
  5. SC impeller
    By shhr in forum 4-Tec Performance
    Replies: 14
    Last Post: 05-02-2005, 09:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •