Results 1 to 5 of 5
  1. #1
    2kflhr's Avatar
    Join Date
    Aug 2009
    Location
    Mooresville, NC
    Posts
    64
    +1
    2

    Oil Pressure Blow-By Solenoid '04 Limited

    I bought this '04 Limited a month or so ago and it has ran great. I had it in the garage today buffing out the gelcoat. I had the seat off and noticed a clicking noise ever so often. I determined it to be the blow-by solenoid looking by at parts diagrams. When I bought the boat the seller had the battery disconnected and this may be the reason. I keep a battery tender on it so I haven't had a dead battery from this solenoid cycling.

    Any ideas what to check? I've had it in my garage most of the day and hadn't heard it until the last little while.


    Thanks in advance for any advice!
    2kflhr


  2. #2
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    tap on the dess post
    it is probably bad

  3. #3
    Pwgsx's Avatar
    Join Date
    Sep 2006
    Location
    DFW- TX
    Posts
    1,196
    +1
    38
    Did you have the dess key on the post? If you did the click is normal, it clicks when it opens and again when it closes 20-30 sec later.

  4. #4
    2kflhr's Avatar
    Join Date
    Aug 2009
    Location
    Mooresville, NC
    Posts
    64
    +1
    2
    Quote Originally Posted by Pwgsx View Post
    Did you have the dess key on the post? If you did the click is normal, it clicks when it opens and again when it closes 20-30 sec later.
    First off, thanks for the replies!

    The DESS wasn't on the post. I was wet sanding the ski to buff out and would hear a click and maybe 20-30 seconds later I would hear another click and the sound of slight pressure relief or purge that sounded like it is was below in the crankcase.

  5. #5
    2kflhr's Avatar
    Join Date
    Aug 2009
    Location
    Mooresville, NC
    Posts
    64
    +1
    2
    TTT, anybody have any ideas what else to check?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 04 185 with oil pressure issues, HELP!
    By JeffSki in forum 4-Tec Performance
    Replies: 11
    Last Post: 07-08-2013, 03:31 PM
  2. 2003 GTX Limited low oil pressure
    By chuck2 in forum 4-Tec Performance
    Replies: 10
    Last Post: 09-20-2012, 12:35 PM
  3. 04 RXP oil pressure
    By jgharen in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 04-19-2009, 06:58 AM
  4. Check This Stuff Out It May Help Our Oil Blow By Prob Let Me Know What Ya All Think
    By Ultra250xryder in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 09-28-2007, 09:07 PM
  5. '04 oil pressure switch failure
    By RXP'in in MI in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-22-2007, 10:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •