Results 1 to 3 of 3
  1. #1

    Join Date
    Sep 2010
    Daytona Florida

    Waterbox coating

    07 Speedster 200 430hp. Look at the coating on the waterbox, both engines show this. I also see a hot spot on the SB engine rubber hose by the pipe going into the box.

    is this an indication of a problem?

  2. #2
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Davison, Mi
    looks like a rub spot not a hot spot
    if your exhaust got hot you would get a warning light
    IMO looks normal....time to upgrade the hp to 520+

  3. #3
    Pwgsx's Avatar
    Join Date
    Sep 2006
    DFW- Tx
    That one deff looks like it got hot at some point. You can pull the J pipe and check the 3 holes for clogs. make sure pump water intake is clear and nothing clogged in the screen.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Waterbox mod.
    By Therock in forum 4-Tec Performance
    Replies: 15
    Last Post: 07-08-2005, 07:22 AM
  2. Why isn't anyone looking into ceremic coatings?
    By 1 FAST VE in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-02-2005, 12:40 AM
  3. Gel Coat
    By jjaco in forum 4-Tec Performance
    Replies: 9
    Last Post: 06-04-2005, 09:28 PM
  4. How loud is the Modded Stock Waterbox
    By johnD in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-23-2005, 11:03 PM
  5. RXP Race waterbox
    By Vern in forum 4-Tec Performance
    Replies: 9
    Last Post: 05-23-2005, 04:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts