Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    Join Date
    Dec 2012
    Location
    MA
    Posts
    146
    +1
    12

    2014 RXT-X 260 grinding/noisy on hard turns anyone else having an issue?

    I bought a new 2014 RXT-X and when I take either a hard left or hard right turn while under power (maybe 1/4 to 1/2 throttle) I can hear like a grinding noise or maybe it's a vibration. Anyone else have an issue with this S3 hull? Is there any way that these hulls are flexing enough to make alignment problems? Maybe it's nothing but it sure doesn't sound right. I also have an 05 RXT and when I do hard turns there is no noise at all. Ski is completely stock w/ 3 hours. Thanks for any input


  2. #2
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,992
    +1
    455

    2014 RXT-X 260 grinding/noisy on hard turns anyone else having an issue?

    I'm certain it's the hull. Noisy

  3. #3

    Join Date
    Jun 2010
    Location
    Chicago, IL
    Posts
    14
    Quote Originally Posted by Scott View Post
    I'm certain it's the hull. Noisy
    Mine makes the same noise. I also believe it to be the hull, though mine will do it at very low iddling speeds as well. Has done it since 0 hours.

  4. #4
    spouk3's Avatar
    Join Date
    Mar 2012
    Location
    Montreal, QC, Canada
    Posts
    635
    +1
    30
    Can it be a bad shaft alignment grinding the carbon seal?

    My RXT came back from the dealer and it's making that grinding sound on hard turn at slow speed. They changed my impeller... I'm returning it to the dealer today

  5. #5

    Join Date
    Dec 2012
    Location
    MA
    Posts
    146
    +1
    12
    Was it making that noise prior to going to the dealer?
    I'm no expert but I would have to think that if something is out of alignment it's always out, unless something is moving or twisting to put it out

    Airgigs, what do you guys think is happening to the hull to make that noise?
    There's no noise on mine going straight or long fast turns, my sponsons are in the center slot, not loose. Dunno

  6. #6
    spouk3's Avatar
    Join Date
    Mar 2012
    Location
    Montreal, QC, Canada
    Posts
    635
    +1
    30
    Wasn't doing it... And they changed the impeller... I don't know... Anyway, that was an input for the thread... I don't want to takeover the topic ☺ mine is back to the dealer and I have a brand new RXP-X for the week ☺

  7. #7

    Join Date
    Jun 2010
    Location
    Chicago, IL
    Posts
    14
    Quote Originally Posted by JohnW View Post
    Airgigs, what do you guys think is happening to the hull to make that noise?
    There's no noise on mine going straight or long fast turns, my sponsons are in the center slot, not loose. Dunno
    It is almost like the sound of cavitation. Really difficult to describe. The ski runs perfect though so I am not sure if its anything to be concerned about.

  8. #8

    Join Date
    Dec 2012
    Location
    MA
    Posts
    146
    +1
    12
    I'm guessing it's not much to worry about. One thing came to mind and that when you turn hard is the "brake bucket" and reverse gate partially out of the water causing this noise/vibration. The reverse gates doesn't follow the nozzle like the older skis and that could be part of it...just a guess

  9. #9
    Bounty Hunter Carlos Thomas's Avatar
    Join Date
    Jul 2007
    Location
    San Leandro, CA
    Posts
    1,401
    +1
    22
    2014 = Warranty. Take it in and say, "Fix it".

  10. +1 by:


  11. #10

    Join Date
    May 2007
    Location
    Minneapolis MN
    Posts
    838
    +1
    127
    Quote Originally Posted by JohnW View Post
    I'm guessing it's not much to worry about. One thing came to mind and that when you turn hard is the "brake bucket" and reverse gate partially out of the water causing this noise/vibration. The reverse gates doesn't follow the nozzle like the older skis and that could be part of it...just a guess
    My '14 RXT makes what sounds like the same noise you describe. I know it's nothing to do with engine/pump alignment because I had this done before I took delivery. I'm not worrying about it but my opinion is that some component on the nozzle touches something (maybe the IBR actuator?) on hard turns so the vibration gets transmitted to the hull.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 01-18-2015, 01:38 PM
  2. Upgrade opinons on 2014 RXT-X 260
    By Titan_Joe in forum 4-Tec Performance
    Replies: 4
    Last Post: 01-06-2015, 09:01 PM
  3. OK so I've got over 5 hours on my 2014 RXT-X 260
    By JohnW in forum 4-Tec Performance
    Replies: 10
    Last Post: 08-02-2014, 09:27 AM
  4. 2012 RXT-X 260... IBR Sticking on?
    By Incorrigible in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-23-2012, 03:16 PM
  5. Riva RXT-X 260 rear exhaust on a 09 GTX LTD iS??? - it fits!!!
    By Green Hulk in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-25-2012, 07:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •