Results 1 to 4 of 4
  1. #1

    2006 stx 15f has no power under load

    Out of the water it runs great , revs all the way to redline but once i put it in it wont rev past 5k. It cuts in and out with a too speed of about 45. So far i checked the fuel pressure and compression and both are perfect as well as changed the plugs and oil. Anyone have any ideas?


  2. #2
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    4,485
    +1
    320
    have you looked for an exhaust leak?

    Sean

  3. #3
    I just fixed an exhaust leak from the header to the waterbox

  4. #4
    Post cyl compression.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2006 STX 15F No Fuel Level on DASH ?
    By shadetreejerry in forum Kawasaki Open Discussion
    Replies: 4
    Last Post: 08-04-2013, 12:14 PM
  2. 94 waveblaster has no power
    By Mark93spx in forum Yamaha Old School Skis
    Replies: 12
    Last Post: 07-13-2011, 01:45 PM
  3. 2008 15F has no secondary muffler
    By 70455gto in forum Kawasaki PWC Performance (4-stroke)
    Replies: 9
    Last Post: 06-03-2010, 10:45 PM
  4. For Sale 2007 Ultra 250X & 2006 STX-15F
    By TheDome in forum Kawasaki Skis
    Replies: 5
    Last Post: 07-12-2009, 01:51 PM
  5. 2006 Stx 15f
    By imax in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 06-09-2008, 07:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •