Results 1 to 10 of 10
  1. #1
    DonVito's Avatar
    Join Date
    Jun 2014
    Location
    Chatsworth, California
    Posts
    23

    Impeller Question

    Hi Everybody,

    I recently purchase 2 used Seadoos from a friend of mine. One of them is a 2005 RXP Race ski that the previous owner used to race and dropped a lot of money into it. He claims it is a 300 hP ski. The RXP has a brand new motor in it with only 1 hour on it. I took them to the lake to try them out. The RXP has a lot of mods. From what I can tell it has a through hull exhaust out the back, R&D Air intake Bigger Super Charger, bigger injectors, R&D Sponsons, R&D intake grate, non stock impeller I don't know the pitch, larger intercooler, blow off valve, high rev spring and retainers, lifters. etc. I talked to the mechanic from the seadoo shop and verified this but I can't get real specific because there are so many mods on this ski and he can't remember. He did tell me that when he put the new motor in the ski he also rebuilt the supercharger and installed the hi rev springs and retainers etc. This ski is STUPID FAST. I did not want to open it up too much because the motor is brand new. It ran great and sounded great. The only issue I had was the checkengine light Code P0326 ( Knock Sensor ). I posted about this and received a lot of help from many on the forum and solved the problem. The problem was the ECU it had a Rotax Racing ECU without Knock control. I installed the Stock ECU and problem solved.

    Now I have a new question. This probably already has been discussed and it is most likely a stupid question but here it goes. I purchased a V-TECH tuner and a licence for this ski so I can tune the stock ECU and after some difficulty with the program and having to text Jonatan from VTECH he had to log into my computer and unlock the tuner and fix some server issues and after a few days it finally worked and I got my tunes. I loaded and installed the 86** RPM tune ( they should call this the Holy Sh*t Tune ).
    It jumps out of the hole incredibly fast! and it makes a rocket jet hissing sound ( like a jet plane ) when it takes off. But it only reached approx 8200 rpm WOT. Is this because of the size impeller it has? As I stated before I do not know what impeller it has but it is definitely not stock and it has a stainless steel wear ring from what I can see when I look through the grate. Thanks for the Help


  2. #2
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    so what tune did you put in your ecu
    8200 could on the rev-limiter

  3. #3
    DonVito's Avatar
    Join Date
    Jun 2014
    Location
    Chatsworth, California
    Posts
    23
    it was the 86** RPM Tune

  4. #4
    DonVito's Avatar
    Join Date
    Jun 2014
    Location
    Chatsworth, California
    Posts
    23
    I will get the exact numbers from my computer when I get home and post

  5. #5
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    IMO ride it until your use to it
    put on a afr gage or logger before you change the prop
    I would put a afr or logger before I rode it ....that's just me

  6. #6
    DonVito's Avatar
    Join Date
    Jun 2014
    Location
    Chatsworth, California
    Posts
    23
    Quote Originally Posted by skidoochris View Post
    so what tune did you put in your ecu
    8200 could on the rev-limiter
    The Tune I loaded is: 42 8650 148 41 29 101

    Does anybody know what the difference is between the tune I loaded and 42 8650 rescaled 2 bar?

    I assume the 8650 is the RPM?

  7. #7
    DonVito's Avatar
    Join Date
    Jun 2014
    Location
    Chatsworth, California
    Posts
    23
    Quote Originally Posted by skidoochris View Post
    IMO ride it until your use to it
    put on a afr gage or logger before you change the prop
    I would put a afr or logger before I rode it ....that's just me
    I think the ski has an afr. Is it a black square box next to the ECU? I think it is stamped RIVA on the side but there is no other markings

  8. #8
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    Don, where are you located? If you are near another GH member, you may have someone willing to stop by and look at your machines and help you identify what you have, which could be really helpful.

  9. #9
    DonVito's Avatar
    Join Date
    Jun 2014
    Location
    Chatsworth, California
    Posts
    23
    Quote Originally Posted by Vern View Post
    Don, where are you located? If you are near another GH member, you may have someone willing to stop by and look at your machines and help you identify what you have, which could be really helpful.
    I live in Chatsworth, California. In the San Fernando Valley about 30 miles Northwest of Los Angeles

  10. #10
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    808
    It is possible that the prop is the issue (along with the summertime heat) but if you could find out from the last owner what RPM the ski used to run at that might help confirm whether you are off a bit or not. Without past history the rest is basically just a guess. You would need to check the compression and do some data logging of some sort to make sure everything is good to go.

    Quote Originally Posted by DonVito View Post
    I loaded and installed the 86** RPM tune ( they should call this the Holy Sh*t Tune ). It jumps out of the hole incredibly fast! and it makes a rocket jet hissing sound ( like a jet plane ) when it takes off. But it only reached approx 8200 rpm WOT. Is this because of the size impeller it has? As I stated before I do not know what impeller it has but it is definitely not stock and it has a stainless steel wear ring from what I can see when I look through the grate. Thanks for the Help

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP impeller Question
    By The Bandit in forum 4-Tec Performance
    Replies: 9
    Last Post: 07-08-2007, 11:30 PM
  2. Guys with NEW RR SCer impeller. Questions!
    By Water4fire in forum 4-Tec Performance
    Replies: 17
    Last Post: 09-19-2006, 01:09 PM
  3. riva stage one and stage 2 impeller question
    By CarFanatic in forum 4-Tec Performance
    Replies: 6
    Last Post: 06-19-2006, 09:31 PM
  4. Impeller question
    By Flying Scotsman in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 02-04-2006, 08:12 PM
  5. Solas impeller question
    By Jeff C in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-03-2005, 11:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •