Results 1 to 8 of 8
  1. #1

    Join Date
    Jul 2007
    Location
    western ky
    Posts
    65

    Polaris genesis starting issue

    2003 polaris genesis doesn't want to start unhook one injector starts right up. Before it got so hard to start it would only reach apx 6100 rpm should be around 6700 I think any idea what would cause this?has new tps and start stop module and new plugs


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by mgm1966 View Post
    2003 polaris genesis doesn't want to start
    unhook one injector starts right up.

    Before it got so hard to start it would only reach max 6100 rpm should be around 6700 I think
    any idea what would cause this?

    has new tps and start stop module and new plugs
    Ficht engine only starting when one fuel injector is unplugged is a classic symptom of weak injector voltage. Which typically means the EMM needs repair.

    Low maximum RPM on the water at speed is indicative of reduced engine power. Check cylinder compression.

  3. #3

    Join Date
    Jul 2007
    Location
    western ky
    Posts
    65
    Just had emm repaired about 5 or 6 weeks back ran ok for a few days then started to cut out and hard to start now pretty much won't start till injector is unplugged.I will check compression tommorow thanks

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by mgm1966 View Post
    Just had emm repaired about 5 or 6 weeks back
    ran ok for a few days then started to cut out and hard to start now pretty much won't start till injector is unplugged...
    What was the repair for?

    Which service did the repair?

  5. #5

    Join Date
    Jul 2007
    Location
    western ky
    Posts
    65
    Ficht emm repair in Texas . I bought the machine after someone jump started it with a car .i knew the emm was probably shot but it has a new sbt engine I think is still under warranty.I need to pull out my paperwork and check the dates and do a compression test.

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by mgm1966 View Post
    Ficht emm repair in Texas .

    I bought the machine after someone jump started it with a car .i knew the emm was probably shot ...
    Unlike the carburetor engines the Ficht EMM does not get power from the battery in the watercraft. Unless the car jumping swapped the battery polarity I would expect an EMM to not be damaged from jump starting. That said, jump starting any Polaris watercraft from a car is a bad idea.

    Did the engine start with the EMM before it was sent out for repair?

  7. #7

    Join Date
    Jul 2007
    Location
    western ky
    Posts
    65
    No it wouldn't start but I took the emm off my 2001 genesis and it cranked up .sent the emm off and when I got it back it would crank .ran we'll for a day or two but topped out at 6200 rpm then got hard to start unplug 1 injector cranks right up.

  8. #8
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by mgm1966 View Post
    No it wouldn't start but I took the emm off my 2001 genesis and it cranked up .

    sent the emm off and when I got it back it would crank. ran well for a day or two but topped out at 6200 rpm then got hard to start

    unplug 1 injector cranks right up.
    Sounds like the EMM power section needs repair.

    Make sure the water cooling for the EMM is actually flowing, not blocked somewhere or hose kinked.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1999 Polaris Genesis fuel issue, Please help.
    By battline in forum Polaris Open Discussion
    Replies: 1
    Last Post: 05-23-2012, 08:07 PM
  2. 2001 Polaris Virage Starting Issues. Please Help
    By sofreshincali in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-23-2010, 12:42 AM
  3. 2001 Polaris Genesis Plaining Issue
    By polarisrider007 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 07-22-2010, 12:36 AM
  4. 99 Genesis starting issue
    By misplaced in forum Polaris How To & FAQs
    Replies: 13
    Last Post: 07-20-2009, 07:35 AM
  5. Polaris Genesis starting prob...
    By grantuk in forum Polaris PWC Performance
    Replies: 17
    Last Post: 01-27-2009, 12:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •