Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    PDQ's Avatar
    Join Date
    Jun 2014
    Location
    Southampton, England
    Posts
    20
    +1
    1

    08 Ultra 250x Problem

    Took the Ski out today, when at full throttle can not get full boost and only about 5900rpm 50mph. Tried on half throttle got 6590rpm 66mph. No cavatation, no fault codes. Pulled the ski out of the water checked s/c belt tension with tensioning tool and belt tension is correct. Out of the water i get full revs about 7600rpm and full boost 10psi. I have removed blow off valve from back of intercooler and fitted a R+D block off plate with gasket, new spark plugs, new oil. Cant see any leaks from exhaust. Please help i am racing next weekend.
    Thanks in advance.


  2. #2

    same

    Quote Originally Posted by PDQ View Post
    Took the Ski out today, when at full throttle can not get full boost and only about 5900rpm 50mph. Tried on half throttle got 6590rpm 66mph. No cavatation, no fault codes. Pulled the ski out of the water checked s/c belt tension with tensioning tool and belt tension is correct. Out of the water i get full revs about 7600rpm and full boost 10psi. I have removed blow off valve from back of intercooler and fitted a R+D block off plate with gasket, new spark plugs, new oil. Cant see any leaks from exhaust. Please help i am racing next weekend.
    Thanks in advance.
    hello, i have same problem, i change more parts and no resolution problem. i test intercooler for leak,new spark,clean injectors,change coil cable and all,change trotle body and blow off valve, and no resolution problem. only ecu i don't change. Is possible guis have this problem ? thanks for your help.

  3. #3
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,763
    +1
    617
    Have you had a real good look and check of all boost hoses

  4. #4
    PDQ's Avatar
    Join Date
    Jun 2014
    Location
    Southampton, England
    Posts
    20
    +1
    1
    Quote Originally Posted by nicjak View Post
    Have you had a real good look and check of all boost hoses
    I will check all the hoses today. Just to confirm are these the hoses going to the intercooler.

  5. #5
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,763
    +1
    617
    Yes everything from the s/c outlet needs to be snug and tight all the way to the inlet throttle body.

  6. #6
    Sorry Nicjak, this is Very easy , manifold are 2 and this operation is Very easy, a ceck and in Very good condition. Repete , i test intercooler leak and no leak, i ceck belt and ok, i ceck and change trotle body with tps and idle valve and not change (remove Parts from ski perfect working) , ignition coli cable and Spark not change ,i test compression and i have 8.4 all cilinder , i change injectors and not change , i clean my injectors and same problem . I don't test only ECU , and i remenber i test fuel pressure and is good , i don't no i use fuel for fire ski.

  7. #7
    PDQ's Avatar
    Join Date
    Jun 2014
    Location
    Southampton, England
    Posts
    20
    +1
    1
    Could this be an impeller problem i.e to much clearance or damaged impeller.
    Any Thoughts much appreciated .

  8. #8
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,763
    +1
    617
    Yes that or boost leak as stated above

  9. #9
    202 guys see this tread and no answere for resolution this problem. BAD Kawa?

  10. #10
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Rockwall , Texas
    Posts
    3,948
    +1
    543
    Not bad kawi. ?.....bad mechanic missing problem !

    Any brand need experience mechanic to fix.......cant not always fix over internet

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 08 Ultra 250x problem
    By wolftrader in forum Kawasaki PWC Performance (4-stroke)
    Replies: 13
    Last Post: 08-29-2013, 11:33 AM
  2. 08 ultra 250x sc problem?
    By drgballz in forum Kawasaki Open Discussion
    Replies: 7
    Last Post: 02-14-2013, 11:32 PM
  3. '08 Ultra 250X Tubing
    By SE TX Rider in forum Videos & Pictures
    Replies: 2
    Last Post: 05-28-2008, 07:09 PM
  4. 08 ultra 250x
    By gary in forum Kawasaki PWC Performance (4-stroke)
    Replies: 11
    Last Post: 05-08-2008, 11:16 PM
  5. The differences from 07' to 08' Ultra 250X
    By Skips313 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 28
    Last Post: 02-09-2008, 01:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •