Results 1 to 7 of 7
  1. #1

    Question Flushing water question

    I notice that when I do my winterizing flush or for one reason or another am running cooling water from a hose to the ski that most of the water just dumps out through the bucket area and not through the water hole. It seems that once it's warmed up more water is dispensed through the water hole but not when it's cold. Is this normal? Both of my skis do this.

    Thanks,
    Brian


  2. #2
    Normal. Most of the water exits through the exhaust, the outlet is over the reverse bucket. You should have a steady warm stream through the pisser when running on hose.

  3. #3
    What is the purpose of the pisser then?

  4. #4
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    To show you cooling is moving through system

  5. #5
    Sea-Donkey's Avatar
    Join Date
    Apr 2012
    Location
    Mississippi
    Posts
    892
    +1
    107
    Quote Originally Posted by JoeyDFZS View Post
    To show you cooling is moving through system
    Right...just like on those things that have been on the back of boats for the past 50+ years.

  6. #6

    Join Date
    May 2014
    Location
    NJ
    Posts
    57
    Quote Originally Posted by JonUF02 View Post
    Normal. Most of the water exits through the exhaust, the outlet is over the reverse bucket. You should have a steady warm stream through the pisser when running on hose.
    X2....!

  7. #7

    Join Date
    Nov 2014
    Location
    St Louis, MO
    Posts
    4
    If the stream from the water hole is weak or non existent that means your one way valve is not operating properly. You can get one from your local dealer for $25.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Flush tee question
    By ssab in forum Polaris Open Discussion
    Replies: 3
    Last Post: 09-26-2009, 12:47 PM
  2. waveraider 1100 flush kit question
    By burton9010 in forum Yamaha Old School Skis
    Replies: 4
    Last Post: 07-29-2009, 11:31 PM
  3. Ocean/Salt Water question???
    By bymorris in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 05-23-2008, 04:03 PM
  4. running ski out of water.... *Questions*
    By HallPass in forum Yamaha Open Discussion
    Replies: 8
    Last Post: 08-30-2007, 12:21 PM
  5. running ski out of water.... *Questions*
    By HallPass in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 08-30-2007, 12:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •