Results 1 to 6 of 6
  1. #1

    Kawasaki ultra 150 help

    I have a kawasaki ultra 150 and as soon as i put the key in and turn it to on my starter starts to spazz out and continuously tries to start and i havent even clicked the start button but when i do it doesnt change anything it keeps just clicking. Before this happened the starter wasnt working well so when i started it i had to hit the starter as i clicked the start button and this worked i just had to do it every time i started the jetski so i ordered a new starter and this problem happened so do you think its still the starter or is there a loose cable somewhere or a problem with the ignition?


  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    285
    Wither the start button is stuck or the starter relay is stuck. Disconnect the wire from the switch to the relay and see what happens. If it still tries to crank the engine, then you know the relay is stuck.

  3. #3
    Quote Originally Posted by steve45 View Post
    Wither the start button is stuck or the starter relay is stuck. Disconnect the wire from the switch to the relay and see what happens. If it still tries to crank the engine, then you know the relay is stuck.
    Alright so i went ordered a new starter relay cause i found out it wasnt the button but when installing the relay i but it together wrong which caused the battery to spark when i went to connect it this made me re setup the relay find the schematic and do it right i hooked up the relay right this time and when i went to turn on the jetski there was no display even though theres power coming from the battery i thought i blew a fuse but my year model doesnt have fuses how do i reset the breaker?

  4. #4
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    285
    Find the breaker and push the button.

    It's probably in the wiring harness in the front top portion of the engine compartment.

  5. #5
    i found two breakers one says main the other says trim but they dont look like they popped out or anything if the breakers are fine what else could i check

  6. #6
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    285
    Push the button.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 kawasaki ultra 150 help
    By jdeez5 in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 07-12-2016, 09:49 PM
  2. F.S. 2001 and 1999 Kawasaki Ultra 150's PARTS
    By signdaddy in forum Kawasaki Classifieds
    Replies: 14
    Last Post: 06-09-2016, 03:47 PM
  3. 2000 kawasaki ultra 150 gas gauge not working HELP
    By dlimz in forum Kawasaki How To & FAQs
    Replies: 1
    Last Post: 05-22-2010, 08:34 PM
  4. Kawasaki Ultra 250 help!!!! please
    By JMC383 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 7
    Last Post: 06-19-2008, 02:24 PM
  5. 01 Kawasaki Ultra 150 - My First Post
    By signdaddy in forum Kawasaki Open Discussion
    Replies: 48
    Last Post: 02-01-2008, 09:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •