Results 1 to 4 of 4
  1. #1
    VdeKock's Avatar
    Join Date
    Nov 2012
    Location
    Netherlands
    Posts
    566
    +1
    37

    Well, That sucks...Bad vibrations :(

    Had some bad vibrations when riding en checked it out on the beach...
    What happend was...

    a hose clamp broke at the rubber exhaust coupler, and the bolt from the Exhaust stay at the bottom came loose...
    Resulting in a broken exhaust inner cover, broken bolt top stay, exhaust stay at bottom damaged, D-Plate cracked

    I never installed the Stay/Bracket attached to the Cilinders and Stay at the Cilinder heads...
    Never was a problem the last 3years...

    I ordered new/used parts already, including the big stay attached to the cilinders, hoping this never happens again
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_7370.jpg 
Views:	44 
Size:	40.8 KB 
ID:	336628   Click image for larger version. 

Name:	IMG_7377.jpg 
Views:	38 
Size:	49.5 KB 
ID:	336629   Click image for larger version. 

Name:	IMG_7378.jpg 
Views:	39 
Size:	55.8 KB 
ID:	336630   Click image for larger version. 

Name:	IMG_7381.jpg 
Views:	42 
Size:	79.6 KB 
ID:	336631  


  2. #2
    powerstroke specialist mikegp's Avatar
    Join Date
    Mar 2011
    Posts
    2,529
    +1
    190
    holy shit!!!
    is the dplate crack?

  3. #3
    VdeKock's Avatar
    Join Date
    Nov 2012
    Location
    Netherlands
    Posts
    566
    +1
    37
    Quote Originally Posted by mikegp View Post
    holy shit!!!
    is the dplate crack?
    unfortunately yes....

    Click image for larger version. 

Name:	IMG_7384.jpg 
Views:	25 
Size:	46.6 KB 
ID:	336642Click image for larger version. 

Name:	IMG_7385.jpg 
Views:	30 
Size:	25.3 KB 
ID:	336643

  4. #4
    powerstroke specialist mikegp's Avatar
    Join Date
    Mar 2011
    Posts
    2,529
    +1
    190
    wow , that's a new one.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bad Vibration
    By John_29455 in forum 4-Tec Performance
    Replies: 6
    Last Post: 09-17-2008, 03:47 PM
  2. 14 hours, lost 200 rpms, hesitates on take off and bad vibration
    By Chris288 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 11
    Last Post: 08-13-2007, 04:21 PM
  3. WELL! That wasn't so bad after all, but now what
    By Shibby1485 in forum Sea Doo Open Discussion
    Replies: 27
    Last Post: 05-27-2006, 01:13 AM
  4. Well!? that didn`t last long...
    By Pale Rider in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 05-18-2006, 08:21 PM
  5. well this sucks
    By jungo in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 08-14-2005, 08:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •