Results 1 to 10 of 10
  1. #1

    1999 Polaris Genesis 1200 Won't REV. Any ideas?

    We were out on the lake and my friend was driving it. He had the throttle pressed in and then it suddenly shot to idle. It is fuel injected and always starts right up but only idles. The throttle cable is moving several components including the butterfly which while it is idling it changes tone but doesn't exactly seem like its bogging down and does not rev up at all. Do you have any idea what this could be? Thanks for any replies.


  2. #2
    ben01251979's Avatar
    Join Date
    Jun 2013
    Location
    Portage, WI
    Posts
    143
    +1
    1
    Sounds like it could be the tps

  3. #3
    Do you know if there is any way to test that?

  4. #4
    ben01251979's Avatar
    Join Date
    Jun 2013
    Location
    Portage, WI
    Posts
    143
    +1
    1
    Other than trying a new one or good used one I'm not sure but a few members on the hulk will give u some excellent Tips and advice on figuring it out

  5. #5
    Yeah, I have been reading other peoples problems and people on here that reply are very helpful. I will go ahead and look for a tps, might be the people I honestly do not know but I am very new to all of this.

  6. #6
    ben01251979's Avatar
    Join Date
    Jun 2013
    Location
    Portage, WI
    Posts
    143
    +1
    1
    What happens when you unplug the tps and start it up does it make a difference than?

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by parson.phillip View Post
    Do you know if there is any way to test that?
    Check the electrical contacts at the TPS for corrosion or looseness. The non-pigtail early TPS sometimes get shaken to death by the engine.

    See my signature links for more TPS related info.

    Even if the current problem turns out to not be the TPS it is always a good idea to have a spare TPS on hand. When you actually need a TPS, there is no working around the problem, other than installing a good one.

  8. #8
    ben01251979's Avatar
    Join Date
    Jun 2013
    Location
    Portage, WI
    Posts
    143
    +1
    1
    K447 when did they start going to the di models just wondering if the emm could also maybe the problem on this ski if it's not carbureted?

  9. #9
    When I remove the EC it doesn't make any difference at all. It only idles. I did not see any corrosion and the Electrical connector goes on really well without much play after connected.

  10. #10
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by parson.phillip View Post
    When I remove the EC it doesn't make any difference at all. It only idles.

    I did not see any corrosion and the Electrical connector goes on really well without much play after connected.
    The engine is supposed to only idle when the TPS is unplugged.

    Until you try another TPS we are just guessing. There are some bench tests you can do on these old style TPS, including ohm tests while the TPS shaft is turned. If the TPS has incorrect ohms or does not smoothly change resistance then it is almost certainly bad.

    The paradox is that even if it all tests good on the bench with an ohmmeter it can still be bad when mounted on a vibrating engine.

    Note: The ohms test as outlined in the Service Manual do not apply to the newer generation TPS. The newer TPS have a chip inside so they are not testable using an ohmmeter.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 Polaris Virage TXi and 1999 Polaris Genesis 1200 Help!
    By Big Willy in forum Polaris Open Discussion
    Replies: 22
    Last Post: 01-23-2016, 11:31 AM
  2. 1999 Polaris Genesis 1200 Won't REV. Any ideas?
    By parson.phillip in forum Open Discussion
    Replies: 1
    Last Post: 07-21-2014, 08:16 PM
  3. F.S. parting 1999 polaris GENESIS 1200 ficht
    By john zigler in forum Polaris Classifieds
    Replies: 51
    Last Post: 11-17-2011, 09:38 AM
  4. 2002 Polaris Genesis I won't rev past 4000 rpm
    By 440/650 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-12-2011, 02:51 PM
  5. 1999 Polaris Genesis 1200 "Sleeper" project
    By SCXtrmSnwNWtr in forum Polaris Projects
    Replies: 23
    Last Post: 05-12-2007, 06:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •