Results 1 to 2 of 2
  1. #1

    1996 sltx 1050 back cylinder not firing

    have a 1996 1050 sltx updated and back cylinder has no spark just started the display was not working that day but now it is did that cause something to not spark or what might be doing this this is wires ski and upset she can't go new to these any help is great

    thanks dan

    red engine if that makes a difference i seen somewhere that display may need reset but not sure how to do this any help
    Last edited by K447; 07-29-2014 at 12:29 PM.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,588
    +1
    1,272
    Welcome

    Just saw your post now.

    You have the Ignition Update Kit installed, correct? Is this a genuine Polaris kit or aftermarket?

    You will need to work through some diagnostics.

    Have you done the various stator ohm checks and Hall effect sensors tests? Also checked the ignition coil ohms?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 SLTX 1050 middle and front cylinder HOT HELP!
    By shogangp in forum Polaris PWC Performance
    Replies: 4
    Last Post: 05-01-2014, 09:27 PM
  2. GPR cylinder not firing...??
    By slowimport in forum Yamaha PWC Performance (2-stroke)
    Replies: 20
    Last Post: 06-18-2009, 04:06 PM
  3. UREGNT**Can I use 40mm carbs on a 1996 sltx 1050
    By motox1027 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 05-22-2009, 06:37 PM
  4. Aft cylinder not firing
    By skyler_lloyd in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 07-14-2007, 01:12 AM
  5. 1996 sltx 1050
    By 1bad69chevelle in forum Polaris PWC Performance
    Replies: 5
    Last Post: 04-01-2007, 07:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •