Results 1 to 10 of 10
  1. #1

    2004 speedster 200 310hp wot rpm ?

    Hi all

    At wot my rpm are at 8100 and getting 48 to50 mph is this normal ??

    Thanks
    Eric


  2. #2
    Pwgsx's Avatar
    Join Date
    Sep 2006
    Location
    DFW- TX
    Posts
    1,196
    +1
    38
    Mine are a little less rpms and hit 52. Maybe you need to replace your wear rings.

  3. #3
    Both wear ring have been changed ...anything else ??
    Thanks
    Eric

  4. #4
    Pwgsx's Avatar
    Join Date
    Sep 2006
    Location
    DFW- TX
    Posts
    1,196
    +1
    38
    Impellers look good? Cant think of anything at the moment. What kind of conditions are you riding in?

  5. #5
    Last time water was like a mirror .... impeller looks Good to me .... how about your out of the hole ?? I have some cavitation i don't know if i would be able to pull some one on ski or wakeboard. ..

  6. #6
    Pwgsx's Avatar
    Join Date
    Sep 2006
    Location
    DFW- TX
    Posts
    1,196
    +1
    38
    Well I am fighting a issue with one engine wont rev evenly with the other till it passes 6000rpms- basically its non responsive BUT IF I push them both to WOT they take off like a rocket- no cavitation.

    Check your carbon rings for wear - they might be sucking air in.

  7. #7
    OK Thanks will check that out ...

  8. #8
    Mine does 7500 rpm at 50mph. Does anyone have a code reader?? when I start the left engine my right engine light comes on with a single long beep, but if I turn the engine off and back on then the light turns off and everything is normal. I'm thinking maybe a service interval reminder??

  9. #9
    Pwgsx's Avatar
    Join Date
    Sep 2006
    Location
    DFW- TX
    Posts
    1,196
    +1
    38
    I got a CanDoo, its a good investment you should look into. IT would list any codes and you can clear them as well. You can also make new keys too. Reset TPS as well.

  10. #10
    VENOM008's Avatar
    Join Date
    Jun 2014
    Location
    Miami Florida
    Posts
    59
    +1
    4
    change the plugs and try again but my 2005 hit the same 50 but with fresh plugs and not to chopy would go 53


    Quote Originally Posted by alcatraz75 View Post
    Hi all

    At wot my rpm are at 8100 and getting 48 to50 mph is this normal ??

    Thanks
    Eric

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 speedster 200 310hp
    By alcatraz75 in forum Sea Doo Sport Boats
    Replies: 3
    Last Post: 07-11-2014, 05:21 PM
  2. 2004 Speedster 200 twin 155
    By Daniell in forum Sea Doo Sport Boats
    Replies: 0
    Last Post: 07-01-2011, 10:13 PM
  3. 07 Speedster 200 430 HP RPM ????
    By ncarbon in forum Sea Doo Sport Boats
    Replies: 7
    Last Post: 07-07-2009, 10:09 AM
  4. Speedster 200 - 310hp or 430hp
    By ocordova in forum Sea Doo Sport Boats
    Replies: 30
    Last Post: 09-02-2008, 04:54 PM
  5. Speedster 200 (310hp) questions
    By Riderman in forum Sea Doo Sport Boats
    Replies: 3
    Last Post: 07-05-2008, 11:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •