Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12

Thread: clutch issue?

  1. #1

    clutch issue?

    I have a 2013 fzs and my clutch is doing something strange. I was riding and all was going good and then no boost. I pulled seats off and checked all the hoses and everything was connected as it was suppose to be. I started the ski got on it and all was good once agin. Rode for a couple more hours with no issues. Went back on the water monday and first time i got on it and guess what it did it agin. Once agin i check all hoses and they are fine start the ski and it runs as it is supposed to. It seems to me that the clutch just didnt enguage on those 2 passes not sure if anyone has some more insight or something else i should check. Thanks in advance for all suggestions


  2. #2
    Quote Originally Posted by vjstassi View Post
    I have a 2013 fzs and my clutch is doing something strange. I was riding and all was going good and then no boost. I pulled seats off and checked all the hoses and everything was connected as it was suppose to be. I started the ski got on it and all was good once agin. Rode for a couple more hours with no issues. Went back on the water monday and first time i got on it and guess what it did it agin. Once agin i check all hoses and they are fine start the ski and it runs as it is supposed to. It seems to me that the clutch just didnt enguage on those 2 passes not sure if anyone has some more insight or something else i should check. Thanks in advance for all suggestions
    Yes sounds like the Clutch. What you are describing is exactly what mine did. The 2014 Clutch is an upgrade from the 2013. I wouldn't ride it again until you have the Clutch inspected; some of the Clutch parts can fall down farther into the engine if you are unlucky.

    Good luck. JB

  3. #3
    I had super charger off earlier this week and it spins only one way and all the teeth are in perfect shape.also it has only 26 hours on it.

  4. #4
    It's almost like a limiter is kicking on in the ecu. The bad thing is my dealer wont warranty it since i added some mods which really drives me crazy

  5. #5
    Quote Originally Posted by vjstassi View Post
    It's almost like a limiter is kicking on in the ecu. The bad thing is my dealer wont warranty it since i added some mods which really drives me crazy
    Wow thats sucks. What mods did you add?

  6. #6
    @JC's Avatar
    Join Date
    Sep 2012
    Location
    The Peoples Republic of Minnesota
    Posts
    1,861
    +1
    994
    Quote Originally Posted by vjstassi View Post
    It's almost like a limiter is kicking on in the ecu. The bad thing is my dealer wont warranty it since i added some mods which really drives me crazy
    He has to unless you've changed the wheel or shaft, the burden of proof is on the dealer to prove that your mods were the direct cause of the failure, it's not your responsibility to prove that it wasn't.

  7. #7
    bscpaint's Avatar
    Join Date
    Apr 2013
    Location
    LongIsland NY
    Posts
    1,278
    +1
    139
    The 13 clutches don't break teeth, that was the 10-12 clutches. You can ride till it blows swap it out and ride it when your done like nothing ever happened.

  8. #8
    Got a blow off valve?

  9. #9
    big john's Avatar
    Join Date
    Sep 2010
    Location
    Cocoa Beach, Florida, United States
    Posts
    3,395
    +1
    598
    its the clutch, seemingly more common with the 13 clutch, mine started doing the same thing at 6 hrs, progressively got worse. I have no warrantee to fall back on, what you might hear is the spags rolling over when you shut the ski off after it stops boosting, I can hear a audible click when mine does it

  10. #10
    Yes i have a tial bov. Good news clutch is on the way bad news getting in there and changing it. Lol

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. False info: Yamaha finally fixes the clutch issue the gen 3 clutch is here
    By corkycat in forum Yamaha PWC Performance (4-stroke)
    Replies: 68
    Last Post: 08-22-2011, 08:17 PM
  2. 2011 clutch issue teething if you will
    By gpr717 in forum Yamaha PWC Performance (4-stroke)
    Replies: 16
    Last Post: 05-17-2011, 01:40 PM
  3. Possible Clutch Issue 3 Hours After Change
    By ercBOOSTED in forum Yamaha PWC Performance (4-stroke)
    Replies: 35
    Last Post: 07-19-2010, 09:38 PM
  4. 2005 RXT clutch issue
    By pieman2004 in forum 4-Tec Performance
    Replies: 13
    Last Post: 07-28-2008, 06:38 PM
  5. Supercharger Clutch issues..
    By arubenstein in forum 4-Tec Performance
    Replies: 14
    Last Post: 07-26-2005, 12:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •