Results 1 to 2 of 2
  1. #1

    95 sl650 no spark (go figure)

    so i picked up a couple 95 650 SL, got one running OK but sometimes it hesitates out of the hole and will even stall so if i give the choke a quick pull or feather the thottle it'll go but the other hasn't had any spark.. it ran twice in the water but only on two cyl and i've narrowed it down to the exciter coil ( i think )

    red/pur to yellow tested .7 ohm
    wht/yel to black tested 222 ohm
    blue/red to red wht tested 66 ohm
    red/wht to grn red tested 0 ohms wont even show it connects to anything so i'm thinking its a broken wire somewhere down the line.. anyways i'm going to pull it all and find out

    my question is in order to pull the flywheel do certain parts need to be at TDC or can i just use a pully and pull it off and then get the three bolts for the stator and call it a day?
    also am i dreaming that its just a broken wire or is it the exciter coil is effed?

    thanks!


  2. #2
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by Vowels771 View Post
    my question is in order to pull the flywheel do certain parts need to be at TDC or can i just use a pully and pull it off and then get the three bolts for the stator and call it a day?
    also am i dreaming that its just a broken wire or is it the exciter coil is effed?

    thanks!
    Pop off the outer cover and you will see what needs removed. The crank does not need to be in any specific position for removal.

    Could be bad, could be a burnt ground wire that also took out another with it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 01 slh 700 no spark going nuts with this one
    By mark32786 in forum Polaris Tech Tips and Info
    Replies: 4
    Last Post: 08-25-2012, 02:00 PM
  2. 1994 Polaris SL650 No Spark
    By cammotorsports in forum Polaris Open Discussion
    Replies: 9
    Last Post: 01-01-2011, 09:44 PM
  3. sl650 no spark
    By allyfonzo in forum Polaris Open Discussion
    Replies: 7
    Last Post: 06-09-2010, 03:58 PM
  4. 94 Polaris SL650 No spark
    By ChopperPilot08 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-06-2008, 06:37 PM
  5. 95' SL750: No spark!
    By SeaBee63 in forum Polaris Open Discussion
    Replies: 19
    Last Post: 07-18-2007, 12:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •