Results 1 to 2 of 2
  1. #1

    95 SL650 rattle noise?

    whenever its running weather it be out of water or in water there seems to be a metal tinging sound coming from the jet pump area, could this be the impeller out of wack or any ideas? i could try and post a video of it if no one has any idea


  2. #2
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Best thing to do is remove and inspect the jet pump. The blades could be hitting the wear ring due to ring swell, or the bearings could be going bad.....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. F/S: '93 SL750 CDI and '95 SL650 CDI
    By kepneriphone in forum Polaris Classifieds
    Replies: 1
    Last Post: 06-24-2009, 11:36 AM
  2. 'bout dead 95 SL650
    By Grufumbly in forum Polaris Projects
    Replies: 37
    Last Post: 04-13-2008, 04:14 AM
  3. Rattling noise in back
    By billywilly in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-04-2007, 09:10 AM
  4. Will a 95' SL650 crank interchange with a 93' SL750?
    By nu2sport in forum Polaris Open Discussion
    Replies: 2
    Last Post: 05-28-2007, 12:11 PM
  5. 95 SL650 stopped running
    By dkpralle in forum Polaris PWC Performance
    Replies: 5
    Last Post: 04-25-2007, 10:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •