Results 1 to 5 of 5
  1. #1

    Took 95' HX out to Cocoa, had issues/beeping, now there's no spark - what's wrong?

    I took my '95 Seadoo HX out to Cocoa on Sunday (Indian River specifically). Ski ran fine for 20-30 minutes, though it likes to die out if you let it idle for too long (carb issue? Rebuilt them a year or two ago). Eventually, it started running poorly, and began producing a long continuous beep, then finally dying out and failing to start (it'd turn over fine). I put it on the beach, let it cool down some, took the plugs out to dry, and turned it over to blow out any excess water. I could get it to start, but only briefly before it'd die out (still had the continuous beeping). Got home late Sunday night and didn't have time to try and flush it out till Tuesday. While attempting to flush, I got it to start and run for all of 5-10 seconds, but it'd die out before I could turn the hose on, or I'd turn the hose on for all of a half second before it'd die out. As of yesterday however, it won't start period, like it has no spark, even after replacing the plugs and cutting the coils back a 1/4" to get fresh wiring.


    Based on this sequence of events, is this something I did in the salt water, or did a coil/CDI/etc. conveniently fail at the same time? What's with the beeping?


    Also as a side note, I've been using Seadoo's mineral oil up until the beginning of this month when I purchased a 1qt bottle of the Walmart brand to top off the oil on the way to a freshwater lake.


  2. #2
    blairwill4's Avatar
    Join Date
    Apr 2014
    Location
    Fort Wayne IN
    Posts
    339
    +1
    1
    Check your compression. Things arent sounding good from a motor stand point. You replaced your fuel lines when you did the carb rebuild correct? And check your plugs and see how they look. chocolate brown is the key. Report back your findings.

  3. #3
    Quote Originally Posted by blairwill4 View Post
    Check your compression. Things arent sounding good from a motor stand point. You replaced your fuel lines when you did the carb rebuild correct? And check your plugs and see how they look. chocolate brown is the key. Report back your findings.
    Fuel lines, filters, etc. were replaced. Plugs have a dark black/brown color to them. Haven't yet run a compression test but will as soon as I'm able to (in the middle of moving right now).

    Thanks!

  4. #4
    big john's Avatar
    Join Date
    Sep 2010
    Location
    Cocoa Beach, Florida, United States
    Posts
    3,395
    +1
    598
    sounds like a fuel issue to me, check compression and spark, dollars to donuts, your filters are plugged in the carbs

  5. #5
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    2,771
    +1
    129
    The long continuous beep on that setup would be the overheat sensor. Maybe it's gone bad, you can ohm it out. Or maybe it overheated and burnt up some rings, do a compression test.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS - Parts Parting out 95 HX
    By getemkustom in forum Sea Doo 2 Stroke Skis
    Replies: 7
    Last Post: 08-25-2015, 02:24 PM
  2. My Other First Ski - '95 HX - sunk and likes to kill switches
    By JheregJAB in forum 2-Stroke Performance
    Replies: 25
    Last Post: 08-02-2013, 08:18 AM
  3. Do you to pinch any hoses to tow 95 hx, 97 GS,
    By 153stars in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-24-2011, 10:08 PM
  4. 95 hx bog issue
    By sschne62 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 07-03-2010, 01:25 AM
  5. Went out today, and had a restarting issue
    By gorey in forum Polaris Open Discussion
    Replies: 4
    Last Post: 06-28-2009, 09:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •