Results 1 to 2 of 2
  1. #1

    1994 Polaris SLT 750 Fuel Gauge issues

    Hey guys, I recently bought a used SLT 750 (1994) and the MFD did not work at all due to corrosion on the fuse terminals. I installed a new fuse holder in the same way the factory does it. The MFD is working fine now, but the fuel gauge reads empty when the tank is full. Any ideas why this would be happening? Oh and also, the oil gauge is fine. Thanks a lot, I really appreciate it.


  2. #2
    Plut's Avatar
    Join Date
    Jun 2010
    Location
    New Mexico
    Posts
    104
    +1
    3
    Its likely the ball on your fuel sending unit has a leak and is no longer floating with the fuel level.

    If you can find just the ball you may be able to get away with just replacing that. If not, I've seen the whole sending unit starting around $25 used.

    Its # 31 in the picture. Part # 2410032


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1994 Polaris SLT 750 problem
    By kickr69 in forum Polaris Open Discussion
    Replies: 12
    Last Post: 08-03-2010, 11:00 PM
  2. 1994 Polaris SLT 750 will a 92 sl 650 pump fit
    By Canadian_Crew in forum Polaris Open Discussion
    Replies: 10
    Last Post: 10-15-2009, 08:53 AM
  3. 1994 Polaris SLT 750 Engine cutting out after repairs
    By kxs in forum Polaris Open Discussion
    Replies: 6
    Last Post: 09-03-2009, 11:16 PM
  4. 1994 Polaris SLT 750
    By silverstang02 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 10-08-2008, 01:53 PM
  5. Help - 3rd MFD on 1994 Polaris SLT 750
    By bkeith in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 06-22-2008, 10:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •