Results 1 to 7 of 7

Thread: Help please..

  1. #1
    Tony Torque's Avatar
    Join Date
    Jul 2014
    Location
    Bradford, MA
    Posts
    92
    +1
    6

    Help please..

    Just installed R&D Boost Box on my 2012 Rxp-x 260. When I turn on the ski it doesn't start up in sport mode. Is the boost box working? I tested the box to make sure it's getting power and it is. I haven't took it to the water yet. It's pretty simple plug n play you really can't install this wrong. Can one of you more experienced guys tell me what's wrong please and thank you.


  2. #2
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Welcome to Greenhulk.

  3. #3
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    you should have looked here before you bought it
    http://www.greenhulk.net/forums/showthread.php?t=190104

  4. #4
    Tony Torque's Avatar
    Join Date
    Jul 2014
    Location
    Bradford, MA
    Posts
    92
    +1
    6
    Quote Originally Posted by skidoochris View Post
    you should have looked here before you bought it
    http://www.greenhulk.net/forums/showthread.php?t=190104
    Thanks man wish I would of read this before. But damn! The boost box doesn't do anything at all? Zero difference compared to stock?

  5. #5
    WickedXP's Avatar
    Join Date
    Aug 2013
    Location
    MASS
    Posts
    366
    +1
    50
    The RIVA scom is a $200 anchor too!!

  6. #6
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by Tony Torque View Post
    Quote Originally Posted by skidoochris View Post
    you should have looked here before you bought it
    http://www.greenhulk.net/forums/showthread.php?t=190104
    Thanks man wish I would of read this before. But damn! The boost box doesn't do anything at all? Zero difference compared to stock?
    Pretty much, unless you pitch your prop the lower the rpms.

  7. #7
    Tony Torque's Avatar
    Join Date
    Jul 2014
    Location
    Bradford, MA
    Posts
    92
    +1
    6
    So it's all false advertisement. Boost doesn't go from 7psi to 10psi. The speed limiter isn't removed. And the REV limiter also doesn't go up. So I should be calling to send it back sense it doesn't work and get my money back.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need HELP Please!
    By GeoRXT in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-30-2006, 08:04 AM
  2. HEy Guys Need Help PLEASE!!!
    By SpeedStang95 in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-06-2006, 01:29 AM
  3. RXT 2005 Loose Hose - HELP PLEASE
    By BrAinZ in forum 4-Tec Performance
    Replies: 5
    Last Post: 04-12-2006, 12:28 PM
  4. Can some one Post! A little Help Please!
    By Angelse68cal in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-04-2005, 07:57 PM
  5. RXP Handling !! Anyone help please
    By rxp_boy in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-17-2005, 02:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •