Results 1 to 2 of 2
  1. #1

    Keep blowing my 20 amp fuse

    I have 4 pin wiring on my truck with a led light on the truck connector that shows when the lights are used. The fuse does not blow until I hook the trailer up and put on the flasher. Any idea on where to start to trouble shoot. I assume that the truck wiring is good because the lights on the 4 pin adapter work all the time and the fuse does not blow until the trailer is hooked up. I looked at the lights on the trailer and there does not appear to be corrosion. Trailer is a double Karavan. Thanks for any help.
    Al


  2. #2
    Found the problem> My Id lights were shorting out. Just disconnected them for now. How important are the Id lights on my trailer. They are cheap to replace but might just leave them off.
    Al

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. BLOWING THE 5 amp fuse on my GTX 4 Tec 2006
    By Logs1212 in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-23-2016, 02:38 PM
  2. 1999 GSX RFI MPEM blowing the 5 amp fuse
    By Waterluvr in forum Sea Doo ECU Support
    Replies: 3
    Last Post: 08-13-2015, 01:59 PM
  3. HELP! 15 amp fuse keeps blowing. 98GTXL Died!
    By G_Man in forum 2-Stroke Performance
    Replies: 8
    Last Post: 09-30-2013, 03:16 PM
  4. 5 amp MPEM circuit keeps blowing fuse
    By roundtopjeff in forum 2-Stroke Performance
    Replies: 4
    Last Post: 08-19-2012, 10:31 AM
  5. maybe theres a quick answer to this...fuse keeps blowing in my gp1300r
    By MJE in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 07-15-2009, 09:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •