Results 1 to 8 of 8
  1. #1

    Join Date
    Aug 2012
    Location
    Margate, FL
    Posts
    9

    Got our Waverunners stuck today. Should I check anything?

    My wife and I were riding in Galveston Bay today and we were taking a break and had the Waverunners shut off and were slightly drifting. My wife drifted into a sand/mud bar and got her ski stuck. While trying to help her I wound up getting mine stuck as well. I just got off and pushed them both off of the bar and into deeper water. Hers started up and took off just fine but my machine sucked up enough sand and mud to partially stop it up. I shut it off and restarted a couple of time and finally passed whatever was stopping it up. We were on our way back to the ramp so we did not ride much after that.

    My question is "What should I check for damage?" I assume they can stand a little mud and sand but I'd like to be sure everything is OK.

    BTW they are both 2006 FXHO Cruisers...


  2. #2

    Join Date
    Dec 2012
    Location
    Indianapolis
    Posts
    50
    +1
    11
    You our may want to start with getting a good flashlight to look closely at the prop, looking for any damage such as chips or gnarled sections on both the leading and trailing edges. If the muck was thick enough to stop the engine then there is a chance the pebbles or other debris chewed up the impeller. Also check the pump veins in the same fashion. Good luck !

    Quote Originally Posted by jpsexton View Post
    My wife and I were riding in Galveston Bay today and we were taking a break and had the Waverunners shut off and were slightly drifting. My wife drifted into a sand/mud bar and got her ski stuck. While trying to help her I wound up getting mine stuck as well. I just got off and pushed them both off of the bar and into deeper water. Hers started up and took off just fine but my machine sucked up enough sand and mud to partially stop it up. I shut it off and restarted a couple of time and finally passed whatever was stopping it up. We were on our way back to the ramp so we did not ride much after that.

    My question is "What should I check for damage?" I assume they can stand a little mud and sand but I'd like to be sure everything is OK.

    BTW they are both 2006 FXHO Cruisers...

  3. #3
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,591
    +1
    4,797
    I agree, close inspection of the pump tunnels and impellers for any damage from small rocks. Also be on the look out for any signs of overheating when you get them back out on the water. Hopefully, you dodged a bullet this time.

  4. #4
    leejax01's Avatar
    Join Date
    Apr 2011
    Location
    Jacksonville
    Posts
    1,161
    +1
    98
    Also check the strainer to make sure no holes are clogged.

  5. +1 by:


  6. #5

    Join Date
    May 2009
    Location
    Nashville, Tn
    Posts
    788
    +1
    90
    Nope. Their both broke now. Perfect excuse to trade them in on a SVHO.

  7. #6

    Join Date
    Aug 2012
    Location
    Margate, FL
    Posts
    9
    Thanks for the replies! Everything looks fine.

    I think I'll install depth finders in them. The Texas Gulf Coast is always muddy so you have no idea how shallow you are till it's too late.

  8. #7
    bscpaint's Avatar
    Join Date
    Apr 2013
    Location
    LongIsland NY
    Posts
    1,278
    +1
    139
    I would be more concerned with the sand that's trapped in the hose or lower manifold.

  9. #8
    Quote Originally Posted by jpsexton View Post
    Thanks for the replies! Everything looks fine.

    I think I'll install depth finders in them. The Texas Gulf Coast is always muddy so you have no idea how shallow you are till it's too late.
    Just take them to clear lake. That's where I ride.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I just got 2 waverunners CHECK IT OUT 750ss and 750xi
    By chrisorbics in forum Kawasaki PWC Performance (2-stroke)
    Replies: 5
    Last Post: 10-04-2016, 08:38 AM
  2. Got our first snow today
    By WATER WOODY in forum Open Discussion
    Replies: 24
    Last Post: 10-06-2009, 06:18 PM
  3. New to PWC's just got 98 GP800, what should I check.
    By ChewyR in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 01-12-2008, 06:57 PM
  4. Got our Rxt-x and Rxp-x Today
    By JeffTurbo601 in forum 4-Tec Performance
    Replies: 42
    Last Post: 01-03-2008, 05:48 PM
  5. Replies: 4
    Last Post: 06-18-2007, 10:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •