Results 1 to 8 of 8
  1. #1
    savageman69's Avatar
    Join Date
    Jun 2014
    Location
    london ontario
    Posts
    245
    +1
    11

    Best prop and wear ring for sl 700

    Noticing my sl 700 feels like its spinning, today i had to tow a brp into shore and it hardly pull it and if i punched it, it seemed to feel like clutch slip.

    So being that its old and likely the original prop and wear ring what is a better option for prop on a stock sl 700 and where is a good (price) place to order new wear ring?


    Thanks guys


  2. #2
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    First off, good to hear that a Polaris machine was pulling in a Doo...

    Secondly, pull your jet pump off and measure the gap between the impeller and wear ring with a feeler gauge. Standard clearance is .002 - .008 with a limit of .020. If your gap is within this tolerance, replacement will not improve performance.

    Also look at the condition of the impeller leading and trailing edges, and the stator's edges as well.

    Lastly, it is quite possible that your jet pump, ride plate, intake grate, or through hull are leaking. Check that the ride plate and intake grate are fully and completely sealed to the hull.

    Check the condition of your through hull bearing carrier and make sure it is fully greased to prevent water or air leakage.

  3. #3
    savageman69's Avatar
    Join Date
    Jun 2014
    Location
    london ontario
    Posts
    245
    +1
    11
    There are no water leaks...hull stays pretty dry tiny bit comes in but not enough to even flip the bilge i keep a close eye and it never pumps....i think water that gets in is from the hood from spinning.

    It has a lot of knicks and dings on the prop i know that i will have to get around to pulling it out her shortly...it runs great just if you do tight circles or spins you can feel its not pushing out fast it is spinning....same as pulling the doo in if i punched it, it felt like wheel spin so to speak.

  4. #4
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by savageman69 View Post
    There are no water leaks...hull stays pretty dry tiny bit comes in but not enough to even flip the bilge i keep a close eye and it never pumps....i think water that gets in is from the hood from spinning.
    I am not referring to water leaking into the hull, but air leaking into the jet pump tunnel area. If there are gaps between the ride plate and hull, the intake grate and hull, or if the through hull isn't well sealed, the high negative pressure in the pump tunnel will actually suck air into the water and ventilate the prop causing a loss of propulsion.....

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,595
    +1
    1,276
    Quote Originally Posted by savageman69 View Post
    Noticing my sl 700 feels like its spinning, today i had to tow a brp into shore and it hardly pull it and if i punched it, it seemed to feel like clutch slip.

    So being that its old and likely the original prop and wear ring what is a better option for prop on a stock sl 700 and where is a good (price) place to order new wear ring?


    Thanks guys
    When the jet pump is properly set up, it can pull hard with almost no spinning/slippage.

    Here is my own jet pump working hard to tow a completely flooded fairly large hull.

  6. #6
    savageman69's Avatar
    Join Date
    Jun 2014
    Location
    london ontario
    Posts
    245
    +1
    11
    thanks blue i will throw some sealant on it and see if it helps.....yah k447 it didnt pull like that at all lol

  7. #7
    savageman69's Avatar
    Join Date
    Jun 2014
    Location
    london ontario
    Posts
    245
    +1
    11
    thanks guys sealant seemed to really help

  8. #8
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by savageman69 View Post
    thanks guys sealant seemed to really help
    Good to hear!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB looking for a stock or aftermarket prop and wear ring
    By b_dolla44 in forum Sea Doo 2 Stroke Skis
    Replies: 6
    Last Post: 09-27-2011, 10:39 PM
  2. WTB WTB stock rxt (06) prop and wear ring
    By Stockrxp in forum Sea Doo Classifieds
    Replies: 4
    Last Post: 04-03-2011, 05:02 PM
  3. FS prop and wear ring
    By GPRXP4ME in forum Sea Doo Classifieds
    Replies: 5
    Last Post: 01-11-2011, 09:41 AM
  4. Solas prop and wear ring clearance question...
    By KeithKman in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-09-2010, 12:59 AM
  5. bit of a grinding / rattle after new prop and wear ring????
    By Simonm3 in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 05-12-2010, 12:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •