Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 41
  1. #1
    XDAILY's Avatar
    Join Date
    Jun 2011
    Location
    N. Wildwood
    Posts
    616
    +1
    29

    Intercooler not adaquately cooling incoming air @ 73 degree water temp or higher

    My ski has been running great since we've had cooler ocean water temperatures until this weekend.
    It seems every time the ocean water rises above 72 degrees my ski throws the P0217 code and goes
    into limp mode.
    So Im guess the intercooler cant adequately cool the air charge entering the intake manifold once this
    happens on account of a clog or some other cooler problem. Before I go and buy a new intercooler does
    this sound correct? And also where and which one should I buy? Suggestions?


  2. #2
    Sanfish's Avatar
    Join Date
    Jun 2014
    Location
    S/E Florida
    Posts
    2,540
    +1
    778
    Quote Originally Posted by XDAILY View Post
    My ski has been running great since we've had cooler ocean water temperatures until this weekend.
    It seems every time the ocean water rises above 72 degrees my ski throws the P0217 code and goes
    into limp mode.
    So Im guess the intercooler cant adequately cool the air charge entering the intake manifold once this
    happens on account of a clog or some other cooler problem. Before I go and buy a new intercooler does
    this sound correct? And also where and which one should I buy? Suggestions?
    This is an engine coolant issue, not intercooler.

    Check for faulty engine temp sensor with ohm meter:
    2300 to 2750 (while sensor is static at 66 to 70 degrees)

  3. #3
    XDAILY's Avatar
    Join Date
    Jun 2011
    Location
    N. Wildwood
    Posts
    616
    +1
    29
    Is it? Im having a hard time finding info on P0217, I know there are 3 temp sensors (exhaust, head, and intake manifold) I thought I read this code referenced the intake manifold temp sensor?

  4. #4
    XDAILY's Avatar
    Join Date
    Jun 2011
    Location
    N. Wildwood
    Posts
    616
    +1
    29
    Haaaaalp!

  5. #5
    Sanfish's Avatar
    Join Date
    Jun 2014
    Location
    S/E Florida
    Posts
    2,540
    +1
    778
    What answer would you like?

  6. #6
    XDAILY's Avatar
    Join Date
    Jun 2011
    Location
    N. Wildwood
    Posts
    616
    +1
    29
    I think the temp sensors are working properly since it only happens in warmer water.

  7. #7
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,038
    +1
    672
    73 degree water is not warm. Even the OEM intercooler with a 137x4 would handle it. Unless you sucked up all kinds of stuff(in which case it would look like a puffer fish) it's not the IC

  8. +1 by:


  9. #8
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    As Sanfish said, p0217 is engine overheat.
    Check your cooloant level.

  10. #9
    XDAILY's Avatar
    Join Date
    Jun 2011
    Location
    N. Wildwood
    Posts
    616
    +1
    29
    Could it be the engine coolant then? The coolant level is at the right level and looks nice and clean, is there a way to back flush it maybe? Appreciate any ideas on why the high engine temp...

  11. #10
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by XDAILY View Post
    Could it be the engine coolant then? The coolant level is at the right level and looks nice and clean, is there a way to back flush it maybe? Appreciate any ideas on why the high engine temp...
    Unfortunatly the cooloing system is pretty sealed, no real way to flush. There is a small drain on the ride plate.
    Thermostat could be stuck/sticking. Maybe add some dye to the cooloant, to see if the coolant is circulating.

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I know this is going to sound dumb, Cool air and cold water riding advice
    By andrewrolltide in forum High Performance Watercraft Safety
    Replies: 22
    Last Post: 05-19-2016, 01:10 PM
  2. I know this is going to sound dumb, Cool air and cold water riding advice
    By andrewrolltide in forum Sea Doo Open Discussion
    Replies: 22
    Last Post: 05-19-2016, 01:10 PM
  3. to cool or not to cool
    By rcab85 in forum Yamaha PWC Performance (4-stroke)
    Replies: 35
    Last Post: 05-17-2016, 11:05 AM
  4. Fizzle Y1000 Intercooler w/ Riva cooling kit for stock IC
    By mhagley in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 01-08-2014, 05:40 PM
  5. Cooling System Air Bleed 2004 MSX 110
    By MarkMikenis in forum Polaris Open Discussion
    Replies: 11
    Last Post: 09-06-2012, 06:48 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •