Results 1 to 10 of 10
  1. #1

    Join Date
    May 2009
    Location
    Broadstairs, Kent, England
    Posts
    138
    +1
    2

    2013 Wake Pro (215), salt on front of engine

    The top and front of my engine on my 2013 Wake Pro (215hp) are always covered in salt after riding (in the ocean obviously). Any ideas if this is normal? I ride reasonably fast and do get bounced around a bit. My mate who has a 2014 GTX 215 doesn't get any salt on the engine. I'm confused as they're both the same hull / engine. Anyone else with a GTX / Wake Pro have this problem?

    Cheers

    Adrian
    Click image for larger version. 

Name:	2014-07-27 16.09.52.jpg 
Views:	79 
Size:	82.4 KB 
ID:	337204Click image for larger version. 

Name:	2014-07-27 16.10.19.jpg 
Views:	73 
Size:	72.6 KB 
ID:	337205Click image for larger version. 

Name:	2014-07-27 16.09.58.jpg 
Views:	73 
Size:	55.7 KB 
ID:	337210


  2. #2
    mist3rburnz's Avatar
    Join Date
    Jul 2014
    Location
    Queens, NY
    Posts
    34
    +1
    2
    Made me think of this

    Click image for larger version. 

Name:	56384_f86d74b81e75a35dd6acf76db97849c2.jpg 
Views:	51 
Size:	31.7 KB 
ID:	337281

  3. +1 by:


  4. #3
    dsteinmann's Avatar
    Join Date
    Apr 2012
    Location
    St Louis
    Posts
    278
    +1
    8
    there is drain holes under the seat

  5. #4
    Quote Originally Posted by ubernoob View Post
    The top and front of my engine on my 2013 Wake Pro (215hp) are always covered in salt after riding (in the ocean obviously). Any ideas if this is normal? I ride reasonably fast and do get bounced around a bit. My mate who has a 2014 GTX 215 doesn't get any salt on the engine. I'm confused as they're both the same hull / engine. Anyone else with a GTX / Wake Pro have this problem?

    Cheers

    Adrian
    I think mine would look the same if not for copious use of XPS lube after riding. I have 8-10 cans of that stuff constantly in use.

  6. #5

    Join Date
    May 2009
    Location
    Broadstairs, Kent, England
    Posts
    138
    +1
    2
    Believe it or not I lube up after every ride (and the drain hole in the glove box has its plug in so I don't think it's coming from there)!

  7. #6
    dsteinmann's Avatar
    Join Date
    Apr 2012
    Location
    St Louis
    Posts
    278
    +1
    8
    Under the seat there is many holes

  8. #7

    Join Date
    May 2009
    Location
    Broadstairs, Kent, England
    Posts
    138
    +1
    2
    I guess my question was to other Wake Pro / GTX riders, do they get salt marks on the engine when riding on the ocean.

  9. #8
    Marky's Avatar
    Join Date
    Jan 2013
    Location
    GB
    Posts
    62
    +1
    2
    Yes - absolutely the same (2014 GTX 215). I used to get the same on my old 2008 RXP X so I filled the seat holes with silicone. That did the trick BUT the seat took a long time to drain the water out. I don't worry about it now, just wash it off and WD 40 it afterwards.. HTH

  10. #9
    em-dubya's Avatar
    Join Date
    May 2010
    Location
    Savannah, Ga
    Posts
    440
    +1
    7
    Just spray the engine down with silicone spray

  11. #10
    baba850r's Avatar
    Join Date
    Sep 2007
    Location
    scotland
    Posts
    673
    +1
    4
    Every ski ive had always looks like that after riding usually worse tbh,Just wash it down well and use a good spray.It wont do any harm so long as u wash it well after you ride.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Wake Pro 215, 2009 - top speed 64.9 mph on GPS
    By R12Xer in forum 4-Tec Performance
    Replies: 2
    Last Post: 04-12-2014, 07:22 PM
  2. 2011 wake pro 215 limp mode
    By Madmike1 in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-03-2011, 09:20 PM
  3. First Impressions/First ride 2010 Wake Pro 215.
    By vonnie in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 04-25-2010, 12:19 PM
  4. Help - Handle on front of hull... ??
    By Autosport in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 08-16-2009, 03:56 PM
  5. Seadoo wake pro 215 good boat ?
    By [email protected] in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 09-25-2008, 08:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •