Results 1 to 7 of 7
  1. #1
    jdt1003's Avatar
    Join Date
    Sep 2011
    Location
    Southern Illinois
    Posts
    74

    1998 Sea Doo XP Ltd Bad MPEM? Start Stop Switch?

    I just rebuilt this Sea Doo Xp with the 951 carb engine. The body probably set for at least 5 years before I got ahold of it. The engine will start and run until shut down. The problem that I am having is that when pressing the start button it will sometimes crank the engine and sometimes the solenoid just buzzes. I am loosing about .9 Volts at the solenoid from the MPEM. The solenoid seems to be engaging and disengaging continuously. I did bypass the MPEM all together and it will crank continuously. There are no beeps at all when connecting the DESS key. I am starting to believe that the MPEM has partially failed, but want to be 100% sure before replacing.

    Thanks in advance!


  2. #2
    LVC's Avatar
    Join Date
    Dec 2013
    Location
    Loire Valley - France
    Posts
    82
    +1
    9
    Sounds more like a bad earth to me - had a similar problem on mine and that was the cause.

    I replaced the earth strap to engine and also doubled one direct to the starter motor (as is done on the later models) - got my beeps back and starts on the button every-time

    I'd start there before spending out on a new MPEM - good luck

  3. #3
    SURFnTURF's Avatar
    Join Date
    May 2007
    Location
    Australia
    Posts
    878
    +1
    11
    98 XPLS have a shitty ground connection under the magneto that rusts out and corrodes as it sits low in the black box.
    Have a look there first as it is a common problem,then go outside the box onto the front of the engine where 3 wires attach to and check those connections.
    Sometimes the contact points inside the solenoid carbon up,the solenoid can be dismantled by drilling out the rivets and check the contact plate points.File them clean and re install and install new pop rivets and it will go for another 10 years

  4. #4
    jdt1003's Avatar
    Join Date
    Sep 2011
    Location
    Southern Illinois
    Posts
    74
    Ok, I removed and cleaned every ground on the machine that I know of, even cut into the ends of the main battery cable to make sure that there is no corrosion, cleaned ll of the connections in the black box as well. Still the same pulsing when pushing the start button. Any other suggestions before I order an MPEM? I replaced the solenoid with a new one.

  5. #5
    I would try a new start button first before a new MPEM

  6. #6
    jdt1003's Avatar
    Join Date
    Sep 2011
    Location
    Southern Illinois
    Posts
    74
    Cut the start stop switch open and checked the connection, and jumped across the wires. Same thing. The start stop switch is wired directly to the plug on the MPEM.

  7. #7
    I have a 1998 xpl mpem with 2 keys for sale .. works perfect..i changed mine as was told it was faulty.. turns out bad earth.. £250

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB - Parts 1998 Sea Doo Xp Ltd MPEM with DESS key
    By jdt1003 in forum Sea Doo 2 Stroke Skis
    Replies: 0
    Last Post: 07-31-2014, 11:43 AM
  2. FS parting out a 1998 sea doo xp limited
    By troy boy in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 10-26-2012, 08:19 PM
  3. WTB WTB Sea doo GTX ltd. Info gauge 1998
    By Vagaondracing103 in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 10-13-2010, 10:35 AM
  4. FS 2003 gpr with 1998 sea doo xp
    By #721 in forum Yamaha 2 Stroke Skis
    Replies: 0
    Last Post: 08-22-2010, 11:47 AM
  5. 95 XP and 95 SP Start/Stop Switch Interchangeable?
    By Hybrid AWD in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 05-27-2008, 02:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •