Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1

    Join Date
    Apr 2012
    Location
    Southern California
    Posts
    308

    MSX 150 SystemIFB module 2410507 troubles

    i just bought a 2004 msx 150 that was missing the start stop module which i know is impossible to find. well after looking for days i finally found one from martos motorsports. he said he had no more new ones.

    they are all on back order so he sold me a used one for 215$
    i just got it today and plugged it in and my ski wouldnt start and when i cranked it smoke was coming out of that module.

    where do i go from here?
    Last edited by K447; 07-29-2014 at 05:39 PM.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,596
    +1
    1,276
    MSX 140 or MSX 150?

    What part number is the module?

  3. #3

    Join Date
    Apr 2012
    Location
    Southern California
    Posts
    308
    Quote Originally Posted by K447 View Post
    MSX 140 or MSX 150?

    What part number is the module?
    Opps sorry it's a msx 150
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	image.jpg 
Views:	56 
Size:	99.6 KB 
ID:	337334  

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,596
    +1
    1,276
    Quote Originally Posted by jetski4ever View Post
    ... martos motorsports ... sold me a used one for 215$

    ... plugged it in and my ski wouldnt start and when i cranked it smoke was coming out of that module...
    Need to figure out whether there is a problem with your machine that is hurting the SIFB module(s) or if you simply received a defective module.

  5. #5

    Join Date
    Apr 2012
    Location
    Southern California
    Posts
    308
    Quote Originally Posted by K447 View Post
    Quote Originally Posted by jetski4ever View Post
    ... martos motorsports ... sold me a used one for 215$

    ... plugged it in and my ski wouldnt start and when i cranked it smoke was coming out of that module...
    Need to figure out whether there is a problem with your machine that is hurting the SIFB module(s) or if you simply received a defective module.
    What on my ski can cause that to happen I've heard the starter solenoid could be to blame could that be the problem

  6. #6
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,389
    +1
    166
    Why was the ski missing the SIFB to start with? Was the original defective, removed and not replaced?

    What's the known story on the ski? Last ran when? What are the other known issues?

    If you jump the starter solenoid with a screwdriver... does it crank?

    Check all the fuses.

    Cheers!

  7. #7

    Join Date
    Apr 2012
    Location
    Southern California
    Posts
    308
    Okay I just bought this ski I payed 900 for it and from what I've been hearing is not a good deal but the ski when I got it had a broken fuel rail and was missing that module completely I powered up the ski and it showed 52.1 hours and 152 psi in each cylinder on my compression gauge this ski looks to be in great shape everything is clean the oil isn't overfilled and is a good color the plugs look fresh this is all I know about the ski.

    what I've done so far I've replace the fuel rail and the module and put a brand new battery and new gas in the tank and after cranking for about 15 seconds or so I could smell that electrical burn and I look back and the module I just bought was smoking and everytime I would crank the engine it would smoke. So I talked to a guy that rebuilds my Emms and he thinks my starter solenoid backfed power and shorted it out is that even possible he told me to unplug it and jump the terminal to get it to start and it still did not start up where do I go from here. And when I jump the solenoid it does crank even just hitting the start button it cranks

  8. #8

    Join Date
    Apr 2012
    Location
    Southern California
    Posts
    308
    Bump

  9. #9
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,389
    +1
    166
    Do you have a service manual? Time to start tracing/checking wires. Gotta be short or something going wrong there to smoke the SIFB. The service manual has diagrams showing where the SIFB connects to the main relay and the ECU and the starting system.

    So, without a working SIFB... it won't start. No known way (that's ever been shared) to bypass it. But as to why your frying yours... that's the hard part. Wish I could be more helpful.

    Cheers!

  10. #10
    hill160881's Avatar
    Join Date
    Jun 2014
    Location
    The delta Ca
    Posts
    2,043
    +1
    246
    A used SIFB is cheaper through webberpower.com About half that cost

    You out will need to call and talk to Randy to order one.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. msx 150s ifb module smoking
    By KRR in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-18-2015, 11:59 PM
  2. Replies: 5
    Last Post: 08-05-2011, 07:50 PM
  3. msx 150 trouble
    By ajballer01 in forum MSX/Matrix
    Replies: 16
    Last Post: 08-01-2011, 09:11 PM
  4. msx 150 possible intercooler trouble
    By Joe dana in forum MSX/Matrix
    Replies: 9
    Last Post: 07-03-2010, 10:34 AM
  5. MSX 150 trouble code interpretation...!
    By Rocky_Road in forum MSX/Matrix
    Replies: 11
    Last Post: 05-24-2008, 11:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •