Results 1 to 5 of 5
  1. #1
    RIVA CREW's Avatar
    Join Date
    Jul 2010
    Location
    Pompano Beach, FL
    Posts
    115
    +1
    29

    RIVA Wear Ring Installation Correction

    RIVA Wear Ring Installation Correction
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	spark wear ring.JPG 
Views:	291 
Size:	92.0 KB 
ID:	337280  


  2. #2
    xdrian's Avatar
    Join Date
    Nov 2008
    Location
    Brisbane Australia
    Posts
    898
    +1
    225
    We'll that makes more sence just fixed mine thanks

  3. #3
    Was this affecting performance?

  4. #4
    xdrian's Avatar
    Join Date
    Nov 2008
    Location
    Brisbane Australia
    Posts
    898
    +1
    225
    not a performance issues its more it the wear ring turns wont cut the water supply make more sence

  5. #5
    Been around for years...seen it all Kawi-Guy's Avatar
    Join Date
    Oct 2006
    Location
    Naples Florida
    Posts
    828
    +1
    27
    Probably a lot of movement happening, chance of a severed or cut water supply hose

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. stainless steel wear ring installation
    By h2jim in forum 4-Tec Performance
    Replies: 28
    Last Post: 11-04-2010, 08:54 PM
  2. SS wear ring installed but IMPELLER touches side
    By 03mustardrockets in forum 4-Tec Performance
    Replies: 22
    Last Post: 08-20-2009, 02:27 PM
  3. Wear ring install
    By race24x in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-08-2008, 07:01 PM
  4. SS wear ring install problems
    By aha in forum 4-Tec Performance
    Replies: 10
    Last Post: 05-08-2008, 08:27 PM
  5. Riva wear ring
    By Mark S in forum 4-Tec Performance
    Replies: 10
    Last Post: 08-19-2006, 08:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •