Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 37
  1. #1
    XDAILY's Avatar
    Join Date
    Jun 2011
    Location
    N. Wildwood
    Posts
    616
    +1
    29

    Components that have FAILED on my 2010 RXT-iS this year

    Just wanted to make a list of failed components that needed to be replaced this year, some of them
    causing the ski to go into Limp Mode making me ride 5mph back to the dock with a screaming steady
    beeeeeeeeeeeeeeeeep!! instrument cluster (that doesn't have a silence or acknowledge button which is
    unbelievably ridiculous ), one time for over an hour ride with A:] my 2 kids on the back and, B:] Saying
    to everyone I passed in crowded Wildwood, "HEY EVERYONE LOOK AT ME, THIS SKI RIGHT HERE IS MESSED UP!".

    Voltage Regulator (rectifier) - $150
    Throttle Body Assembly - $700
    Head Temperature Sensor - $50
    Rear Hatch Shock Assembly - $40

    Note 1: (If I didn't have amazing helpful friends from this site the fixes above would have been in the
    thousands from labor/parts. Special thanks to BEECHFRONT). To replace the throttle body the suspension
    deck needed to be lifted.

    Note 2: The parts above in my opinion wouldn't fail from abuse/misuse.

    Just want to point out BRP this unacceptable for a top of the line Ski that only saw 3 seasons and 60 hrs.
    From what I have read some have had better luck and some worse. So mine seems about middle of the road.

    BOTTOME LINE: My 2007 RXT made me brand loyal, this ski although IS amazing when it works right has made
    me question the Seadoo Brand.


  2. #2
    Disappointing for sure. The difference in cost between making a product that is reliable and not is negligible. I'd like to see BRP step up and at least handle the paying customers who get the bad ones with repetitive known issues.

  3. #3
    XDAILY's Avatar
    Join Date
    Jun 2011
    Location
    N. Wildwood
    Posts
    616
    +1
    29
    I sent this write up to BRP this morning. They may lose me as a repeat buyer after this ski.
    Really eyeing up some FX SHO's this weekend on the beach.

  4. #4
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,993
    +1
    455
    I don't see how it's brp's fault. Didn't you buy the ski used? All service records well maintained? You should go back to whom it was purchased from and see what can be done. I ride with 8 different s3's all salt water and can't recall a single one experiencing issues like you. Are you certain that ski wasn't flooded?

  5. +1 by:


  6. #5
    Quote Originally Posted by Scott View Post
    I don't see how it's brp's fault. Didn't you buy the ski used? All service records well maintained? You should go back to whom it was purchased from and see what can be done. I ride with 8 different s3's all salt water and can't recall a single one experiencing issues like you. Are you certain that ski wasn't flooded?
    ^^^^^You really think the seller is gonna help? They're gonna laugh in this guy's face and tell him to take a walk. This IS BRP's fault. All these problems in one year on a 2010 ski? C'mon!

  7. #6
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    Quote Originally Posted by crueldude View Post
    Quote Originally Posted by Scott View Post
    I don't see how it's brp's fault. Didn't you buy the ski used? All service records well maintained? You should go back to whom it was purchased from and see what can be done. I ride with 8 different s3's all salt water and can't recall a single one experiencing issues like you. Are you certain that ski wasn't flooded?
    ^^^^^You really think the seller is gonna help? They're gonna laugh in this guy's face and tell him to take a walk. This IS BRP's fault. All these problems in one year on a 2010 ski? C'mon!

    That is a 4 year old ski that we have no idea if it was maintained prior to this guy owning it...BRP wont do anything either....Like Scott said, its not BRPs fault...Dont see how it would be????

  8. +1 by:


  9. #7
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,993
    +1
    455
    Quote Originally Posted by crueldude View Post
    Quote Originally Posted by Scott View Post
    I don't see how it's brp's fault. Didn't you buy the ski used? All service records well maintained? You should go back to whom it was purchased from and see what can be done. I ride with 8 different s3's all salt water and can't recall a single one experiencing issues like you. Are you certain that ski wasn't flooded?
    ^^^^^You really think the seller is gonna help? They're gonna laugh in this guy's face and tell him to take a walk. This IS BRP's fault. All these problems in one year on a 2010 ski? C'mon!
    No sir, BRP will laugh. If I sold a ski and these symptoms came about, I sure as heck would step up and help the man out. Clearly there's more to it than we all know. Sounds like it sunk then dumped.

  10. #8
    eb87's Avatar
    Join Date
    May 2010
    Location
    South East Coast
    Posts
    566
    +1
    25
    I'd be upset about the throttle body, the rest is salt water related mickey mouse shit.

  11. #9
    XDAILY's Avatar
    Join Date
    Jun 2011
    Location
    N. Wildwood
    Posts
    616
    +1
    29
    Service records show it was well maintained and not sunk. The issues it has had are not from misuse or abuse, like I said, but plainly poor electronic components that failed in 3 years and 60 hours which is a joke. Im an electrical engineer by trade things can be made well to last or be made cheap and fail regardless of environment. BRP chose these electronic components from available vendors and chose cheaply/poorly.

  12. #10
    XDAILY's Avatar
    Join Date
    Jun 2011
    Location
    N. Wildwood
    Posts
    616
    +1
    29
    Oh and btw my friend with the same exact year and model just lost his engine when a piece of the valve broke off and fell into the cylinder. Scary stuff for 100 hrs.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Blew up my 2010 rxt-is
    By BEECHFRONT in forum 4-Tec Performance
    Replies: 49
    Last Post: 08-04-2014, 09:26 PM
  2. 2010 RXT-iS this weekend Ski Porn
    By XDAILY in forum 4-Tec Performance
    Replies: 9
    Last Post: 05-28-2014, 07:05 AM
  3. Still having problem with power on my 2005 RXT
    By ndarimont in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-31-2011, 07:39 PM
  4. Embarrasing Newb question on my new RXT
    By 2006 RXT in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-11-2007, 04:11 PM
  5. Help, having problems with my 2005 RXT, low hours
    By 05rxt in forum 4-Tec Performance
    Replies: 6
    Last Post: 04-10-2006, 11:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •