Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 33

Thread: RIVA ecu

  1. #1
    Steve-m31164's Avatar
    Join Date
    Jan 2013
    Location
    Melbourne Australia
    Posts
    2,690
    +1
    403

    RIVA ecu

    Just wondering if anyone can tell me How do I check if my ECU is not working correctly ie: knock and timing ? its a 07+ RIVA 8650 rpm

    Steve


  2. #2
    Boost addict hotbird's Avatar
    Join Date
    Jul 2011
    Location
    Southern WI
    Posts
    5,503
    +1
    681
    its junk get a Motec. LOL Kidding.


    Don't think its possible? OR

    maybe some kinda logger could show you?

  3. #3
    Steve-m31164's Avatar
    Join Date
    Jan 2013
    Location
    Melbourne Australia
    Posts
    2,690
    +1
    403
    How did I know you would say that .....lol

  4. #4
    Steve-m31164's Avatar
    Join Date
    Jan 2013
    Location
    Melbourne Australia
    Posts
    2,690
    +1
    403
    Just wondering if there is a way to TEST this ECU . to see if it is working correctly

  5. #5
    GGG's Avatar
    Join Date
    Sep 2009
    Location
    Jersey Shore
    Posts
    2,830
    +1
    258
    Put another one in and check for differences?

  6. #6
    warsawspeedfreak's Avatar
    Join Date
    Jan 2010
    Location
    Tinley Park, IL
    Posts
    369
    +1
    19
    Quote Originally Posted by Steve-m31164 View Post
    Just wondering if there is a way to TEST this ECU . to see if it is working correctly
    Yes...put on the dess key and push the start button...Find open water and mash the f'ing gas and feel the breeze! No breeze...it's not working!

  7. #7
    Steve-m31164's Avatar
    Join Date
    Jan 2013
    Location
    Melbourne Australia
    Posts
    2,690
    +1
    403
    E=warsawspeedfreak;2434415]
    Quote Originally Posted by Steve-m31164 View Post
    Just wondering if there is a way to TEST this ECU . to see if it is working correctly


    Yes...put on the dess key and push the start button...Find open water and mash the f'ing gas and feel the breeze! No breeze...it's not working![/QUOTE]

    Haha thanks
    I did try that and yes you are correct .
    BUT i would like it to last more that 4hrs on a new engine.
    Witho

  8. #8
    Steve-m31164's Avatar
    Join Date
    Jan 2013
    Location
    Melbourne Australia
    Posts
    2,690
    +1
    403
    Fucking phones

  9. #9
    Steve-m31164's Avatar
    Join Date
    Jan 2013
    Location
    Melbourne Australia
    Posts
    2,690
    +1
    403
    The motor has detonation ....just asking if there is a way to ELECTRONICALLY test the ecu for faults ..or maybe test the knock senser itself . .

  10. #10
    race jase's Avatar
    Join Date
    Feb 2007
    Location
    auckland nz
    Posts
    539
    +1
    46
    There is no test as such you can do to test the ecu,
    Make sure your TPS has been reset for a start.
    If you had a issue with your knock sensor you would get a fault come up, the sensor and wiring are quite sensitive in this area.
    The riva ecu has a massive amount of timing at WOT its around 37 deg.
    Jase

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. B-kit using Riva Ecu
    By rxpdoo in forum 4-Tec Performance
    Replies: 3
    Last Post: 10-18-2006, 09:06 AM
  2. Riva Ecu
    By luismendez25 in forum 4-Tec Performance
    Replies: 3
    Last Post: 09-13-2006, 08:54 PM
  3. Do you guys think Rivas ECU will be milder than Rotaxs
    By excess in forum 4-Tec Performance
    Replies: 8
    Last Post: 07-22-2006, 07:57 PM
  4. Riva ECU
    By idizzy in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-18-2006, 02:02 PM
  5. RR Racing ECU vs. Riva ECU
    By johnD in forum 4-Tec Performance
    Replies: 13
    Last Post: 06-30-2006, 06:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •