Results 1 to 6 of 6
  1. #1

    1996 SL780 Weak Spark

    Hello, still working on this a little. I put the box together and noticed I had spark just weak center spark. I tested the - neg post of my battery to the spark plug hole and was at 0 ohms. Ive tested the magneto and coils and all are within or close to spec… now I'm leaning towards the CDI box itself any thoughts? Thanks Jon
    Also if I buy on what years or models are compatible like the SL SLX SLT 780/750 and what not


  2. #2
    johnsonmtz's Avatar
    Join Date
    Oct 2006
    Location
    Mt. Zion Illinois
    Posts
    1,250
    +1
    7
    Did you trim the plug wires by 1/4" yet? That is a quick first, free place to start before you start diagnosing and replacing other parts.

  3. #3
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Yep - And check your grounds. Just had a member chasing a weak/no spark on the CEN for about a month to find out the ground cable to the bed plate wasn't making good contact.....

    Any year 780 CDI will drop in for yours. A 750 CDI from any year other than 93 will also work, but will lack a few features....

  4. #4
    Click image for larger version. 

Name:	jet ski.jpg 
Views:	44 
Size:	21.1 KB 
ID:	337614
    Thanks, here is what I am getting for spark, i'm used to much more so thats why I'm stumped!! I have cut the plug wires and added an extra ground wire even though it tested Oohms and nothings changed. Any ideas Thank

  5. #5
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Are you having issues with the motor not running, or the CEN not heating up to temp??? Or are you just not satisfied with how the spark "looks". Did you use a spark tester, the kind with a led light in it?

  6. #6
    Well Im just not happy with the spark level. I haven't gotten it running yet I was in the process of getting the engine aligned then thought i had no spark. I haven't tried a spark tester yet so Ill grab one today

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 Polaris SL780 No spark
    By duckdrive in forum Polaris PWC Performance
    Replies: 10
    Last Post: 07-19-2015, 11:29 AM
  2. Help 1996 SL700 weak spark its driving me crazy can any one help
    By JDLHP in forum Polaris Open Discussion
    Replies: 9
    Last Post: 07-22-2014, 04:30 PM
  3. 1996 SLTX weak spark after adding small battery ground
    By ssmi291 in forum Polaris Open Discussion
    Replies: 8
    Last Post: 08-20-2013, 09:48 PM
  4. 1996 polaris sl780 no spark Everything I have tested is good
    By sarah719 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 08-31-2011, 10:49 PM
  5. pro 785 CDI box in 1996 SL780...newbe from PWCtoday here!
    By jcc011185 in forum Polaris PWC Performance
    Replies: 18
    Last Post: 09-24-2006, 09:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •