Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    roundtopjeff's Avatar
    Join Date
    Aug 2011
    Location
    Clarkston Michigan
    Posts
    64
    +1
    1

    03 RXDI will not start

    I am on vacation on Harsen's Island MI. so I have no access to Seadoo repair service.
    I took my great running RX around the island yesterday which is about a 45 min ride and when I got back it would not start.It has spark and a fair amount of vapor shooting out of the cyls so I assume it has fuel too. Has this ever happened to anyone, if so what was it?


  2. #2
    roundtopjeff's Avatar
    Join Date
    Aug 2011
    Location
    Clarkston Michigan
    Posts
    64
    +1
    1
    Today I had a chance to check fuel pressure. 27 or 28 psi when DESS is attached. I also have spark (I can see the the plug firing) when I crank it over. It just will not fire. Can not do real compression test but it spits my finger tip out real good. Both cyls.
    This machine ran fine until I shut it down on shore. It immediately would not start.
    Which sensors would you guess most likely to keep it from starting. We have 2 other DIs the same year here that I can swap parts with.

  3. #3
    roundtopjeff's Avatar
    Join Date
    Aug 2011
    Location
    Clarkston Michigan
    Posts
    64
    +1
    1
    Nobody on this forum has any advise? I am on vacation here.

  4. #4
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,523
    +1
    1,270
    likely the fuel pump..sudden death with no maint warning. You can pull the pump and check the sock if you want to end your holiday and start tinkering with a jetski.

    I think a bottle of your favorite spirits will take away the pain for a while.

  5. #5
    roundtopjeff's Avatar
    Join Date
    Aug 2011
    Location
    Clarkston Michigan
    Posts
    64
    +1
    1
    Update: I installed a spare "new" fuel pump we had on hand with no different result....still will not start. It will spit a backfire now and then and yes "Jack and Coke" will dull the pain.

  6. #6

    Join Date
    Dec 2006
    Location
    Australia
    Posts
    51
    Does it fire up if you pour some fuel into the plug holes and turn it over?

  7. #7
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,523
    +1
    1,270
    I'd suggest having a very close look at the braided line that comes from the airpump outlet to the fuel rail.

    you could have a problem there with a blown line which wouldn't allow the air injectors to atomize the fuel correctly. Low air pressure will not trip a maint warning, as a faulty air or fuel injector could.

    might want to swap the coils out from your running ski as a test, coil could be weak under load, unless the spark is lightning like, could be an issue in the combustion chamber.

  8. #8
    roundtopjeff's Avatar
    Join Date
    Aug 2011
    Location
    Clarkston Michigan
    Posts
    64
    +1
    1
    I just tried gas in the plugs and it would not start.

  9. #9

    Join Date
    Dec 2006
    Location
    Australia
    Posts
    51
    Try changing the plugs over, then i would try the coils /leads.

  10. #10
    roundtopjeff's Avatar
    Join Date
    Aug 2011
    Location
    Clarkston Michigan
    Posts
    64
    +1
    1
    The 1st thing I tried was new plugs and I replaced the coils last summer when I had a plug fouling/ low rpm problem. I did replace them with a used set so I guess I could try the old set...easy enough to change.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1998 Polaris SLXH 1050 will not start
    By sschoeffler in forum Polaris Open Discussion
    Replies: 16
    Last Post: 04-11-2012, 03:40 PM
  2. 03 turbo will not start
    By kristoffer in forum Honda Open Discussion
    Replies: 6
    Last Post: 08-21-2009, 12:54 PM
  3. will not start HELP
    By Neal Van in forum Polaris Open Discussion
    Replies: 6
    Last Post: 07-01-2007, 07:10 PM
  4. my 94 polaris 750 will not start!
    By ducatifreak152 in forum Polaris How To & FAQs
    Replies: 13
    Last Post: 06-03-2007, 12:52 AM
  5. RXP will not start, PLEASE HELP!
    By TroyRXP15 in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-27-2007, 05:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •