Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    Join Date
    Sep 2013
    Location
    South Carolina
    Posts
    38

    04 GTX SC 185 Riva Waterbox/Rear Exhaust Question

    Hey guys,

    Quick question...I'm installing a Riva stage 1 kit and Riva waterbox and rear exhaust on my 04 GTX SC 185. I think I know the answer to this but the directions don't really say and I want to make sure. Do I remove the brass inlet at the end of the exit tube on the Riva waterbox and replace it with the brass plug they provided? I don't think I have a water line to connect there. Is that only for 215hp skis? All that I see is the short hose on top and short hose on bottom right where the J pipe connects to the engine and then I have a hose coming from the back of the ski that I believe goes to the inlet on the top of the J pipe. So am I overlooking a hose or should I plug the brass one at the rear of the Riva waterbox with the brass plug they provided. Thanks for the help.


  2. #2
    RXP 260 X Short Course Veteran RXP244's Avatar
    Join Date
    May 2007
    Location
    Auckland, New Zealand, New Zealand
    Posts
    1,244
    +1
    104
    Where the J-Pipe meets the exhaust, on the under side, the short hose did or should have a "T" in it and the hose from that is what you connect to that brass fitting. Maybe your ski has had that changed at some point?

    So if it has, just plug it.

  3. #3

    Join Date
    Sep 2013
    Location
    South Carolina
    Posts
    38
    Quote Originally Posted by RXP244 View Post
    Where the J-Pipe meets the exhaust, on the under side, the short hose did or should have a "T" in it and the hose from that is what you connect to that brass fitting. Maybe your ski has had that changed at some point?

    So if it has, just plug it.
    I bought my ski new in 04 so I know it has not been changed. I'm wondering if the T you are talking about is only on RXP/RXT models and the GTX 185 should just be plugged?

  4. #4
    RXP 260 X Short Course Veteran RXP244's Avatar
    Join Date
    May 2007
    Location
    Auckland, New Zealand, New Zealand
    Posts
    1,244
    +1
    104
    Quote Originally Posted by derekd7987 View Post
    Quote Originally Posted by RXP244 View Post
    Where the J-Pipe meets the exhaust, on the under side, the short hose did or should have a "T" in it and the hose from that is what you connect to that brass fitting. Maybe your ski has had that changed at some point?

    So if it has, just plug it.
    I bought my ski new in 04 so I know it has not been changed. I'm wondering if the T you are talking about is only on RXP/RXT models and the GTX 185 should just be plugged?

    Yep, your right, I've just checked and the 185 had no T, so just plug it.

  5. #5

    Join Date
    Sep 2013
    Location
    South Carolina
    Posts
    38
    Quote Originally Posted by RXP244 View Post
    Quote Originally Posted by derekd7987 View Post
    Quote Originally Posted by RXP244 View Post
    Where the J-Pipe meets the exhaust, on the under side, the short hose did or should have a "T" in it and the hose from that is what you connect to that brass fitting. Maybe your ski has had that changed at some point?

    So if it has, just plug it.
    I bought my ski new in 04 so I know it has not been changed. I'm wondering if the T you are talking about is only on RXP/RXT models and the GTX 185 should just be plugged?

    Yep, your right, I've just checked and the 185 had no T, so just plug it.
    awesome. thanks man. thats what i was thinking but the instructions said that plug was for using the riva waterbox with the stock exhasut???? lol. just wanted to ask some experienced people to be sure cuz im a noob. thanks again

  6. #6
    Yanksfan's Avatar
    Join Date
    Apr 2012
    Location
    Miami
    Posts
    440
    +1
    19
    no t, did it on mine just block it, if you all b installing a ic in the future u can connect the intercooler pisser to that exit of the water box

  7. #7

    Join Date
    Sep 2013
    Location
    South Carolina
    Posts
    38
    Quote Originally Posted by Yanksfan View Post
    no t, did it on mine just block it, if you all b installing a ic in the future u can connect the intercooler pisser to that exit of the water box
    Thanks man. Man the gtx is a pain to work on since it has no cowl to remove like the rxp. Got the tip done but lining up the waterbox and connecting it to the tip is being a pain.

  8. #8
    Yanksfan's Avatar
    Join Date
    Apr 2012
    Location
    Miami
    Posts
    440
    +1
    19
    Yup, I know the feeling. Good luck and post ur results

  9. #9

    Join Date
    Sep 2013
    Location
    South Carolina
    Posts
    38
    So last night I finally had time to button up the ski. Put the charger back on after having it rebuilt by Jerry and installed most of my Riva Stage 1 kit and the Riva waterbox and rear exhaust. My impeller and SS wear ring haven't come in yet so I haven't installed the pump wedge as I will do it when I do the impeller and wear ring later.

    I'm taking it to my parents Lake to ride it today as I just want to make sure everything is good with what I have done so far since the impeller and wear ring won't be here til atleast another week or so. Anything in particular I need to pay attention to when testing. My main thing I was gonna look for was water leaks at all the plugs/block offs ect. How will having no pump wedge and the stock impeller on affect my speed and rpms?

    Thanks

  10. #10

    Join Date
    Sep 2013
    Location
    South Carolina
    Posts
    38
    so i tested yesterday with the riva waterbox and rear exhaust and all of the riva stage 1 kit EXCEPT the pump wedge and 13/20 impeller. my results were 63 mph on gps and 7650 rpm. so my question is why do i need the 13/20 impeller? i thought a lower number on the trailing edge would reduce top speed? what is going to be the difference if i put on the 13/20?

    thanks

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 04 Sea Doo GTX SC 185 hp
    By Yamahaduster in forum Sea Doo Open Discussion
    Replies: 14
    Last Post: 03-16-2013, 09:40 PM
  2. WTB Driveshaft for 04 GTX SC 185
    By lemon4879 in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 05-23-2012, 06:33 PM
  3. GTX SC Rear Exhaust Question???
    By Drummer0314 in forum 4-Tec Performance
    Replies: 11
    Last Post: 01-15-2009, 10:45 AM
  4. What is an 04 GTX SC...
    By Pale Rider in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 05-10-2006, 07:45 PM
  5. '04 GTX SC RPM
    By 05Limited in forum 4-Tec Performance
    Replies: 6
    Last Post: 03-18-2006, 09:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •