Results 1 to 8 of 8
  1. #1

    08 RXP-X Electrical Issue

    So I was riding along ski started fine, riding along and it started to lose power. Tried a pull and it would only go to 6000 rpms. Shut it off, rocked it etc and it wouldnt start back up. Getting 2 beeps right away when I put the key on like I should. I needed a new battery anyways so I got one and still the same issue. Getting voltage on both sides of the solenoid when I try to start it (7-8V). Seems like the started is drawing current. Ground on the battery is all cleaned up. I was looking on the engine, the ground from the battery goes to the back which i cant get at. Theres 2 small grounds up front that i dont know what they are for. Just wondering if anyone has any ideas of what it might be, thanks.


  2. #2
    sero901's Avatar
    Join Date
    May 2014
    Location
    Canada
    Posts
    56
    +1
    7
    sounds like the motor might be seized up. The loss in rpm could have been a major s/c failure which lodged some metal where you don't want it. pull the supercharger and inspect. Might be able to look in and examine the flywheel. just a thought but thats where i would start.

  3. +1 by:


  4. #3
    Boost addict hotbird's Avatar
    Join Date
    Jul 2011
    Location
    Southern WI
    Posts
    5,503
    +1
    681
    Yup check the supercharger. The bearings might have locked up.

  5. #4
    I was thinking the motor too but it didnt stall and no CEL ( did throw a p1513 i think which is an electrical issue ) . I Just had the supercharger done 20 hrs ago so hopefully its not that.

  6. #5
    Boost addict hotbird's Avatar
    Join Date
    Jul 2011
    Location
    Southern WI
    Posts
    5,503
    +1
    681
    Might be the starter.

    Pull the charger. If that looks good then possibly the starter. Or pump bearings.

  7. #6
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Sounds bad. Pull the SCer for sure, next pull valve cover.

  8. #7
    Yeah im thinking SC for sure, just had it rebuilt 20 hrs ago which is a piss off. Is what it is though.

  9. #8
    Kiwi spanner handler
    Join Date
    Dec 2007
    Location
    Christchurch NewZealand
    Posts
    579
    +1
    13
    if the prop comes loose in the jet unit it can push on the crankshaft giving similar symptoms

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. '08 RXP-X Finger Throttle issue
    By Water Pig in forum 4-Tec Performance
    Replies: 12
    Last Post: 08-10-2012, 04:31 AM
  2. Weird electrical issue, 08 RXTX, whats with this?
    By mstennes in forum 4-Tec Performance
    Replies: 8
    Last Post: 07-16-2011, 12:00 PM
  3. Replies: 8
    Last Post: 09-04-2010, 10:02 PM
  4. FS 08 RXP Complete minus engine/electrics/driveline
    By developerjj in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 03-29-2010, 10:24 PM
  5. Help With RXP Electrical Issue
    By JeffSki in forum 4-Tec Performance
    Replies: 3
    Last Post: 01-11-2009, 01:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •