Results 1 to 9 of 9
  1. #1
    PWC Addict Magnummmmmmmmmm's Avatar
    Join Date
    Jan 2014
    Location
    SML, VA
    Posts
    337
    +1
    47

    2013 RXT-X 260 keypad error

    My TX is throwing a fault for rh keypad error and I can't use my mode or set buttons. Anyone had this problem? Perhaps someone has an easy fix since I'm on vacation 6 hours from my dealer? Thanks!


  2. #2
    Kaybat's Avatar
    Join Date
    Aug 2005
    Location
    Fl
    Posts
    1,735
    +1
    28
    you're screen name......seriously........are you 13?

  3. #3
    PWC Addict Magnummmmmmmmmm's Avatar
    Join Date
    Jan 2014
    Location
    SML, VA
    Posts
    337
    +1
    47
    Thanks for the input about my switch problem! Btw yea I'm 13. Daddy bought me a rxt and I broke it.


  4. #4
    Boost addict hotbird's Avatar
    Join Date
    Jul 2011
    Location
    Southern WI
    Posts
    5,503
    +1
    681
    Probably need to replace the button switch pad thing. If you have tools and a ohm meter you can test it.

  5. #5
    PWC Addict Magnummmmmmmmmm's Avatar
    Join Date
    Jan 2014
    Location
    SML, VA
    Posts
    337
    +1
    47
    Quote Originally Posted by hotbird View Post
    Probably need to replace the button switch pad thing. If you have tools and a ohm meter you can test it.
    I did some more tinkering and I do believe it's a faulty keypad. I was hoping it was a loose connection or something common and easy to fix. Oh well. 7 days into my first 4tec and a trip to the dealer when I get home. I'll report back with what they say. Thanks for the input!

  6. #6
    pummsgtx255's Avatar
    Join Date
    Apr 2013
    Location
    Hamburg NY
    Posts
    64
    +1
    3
    same thing happened to my 09 gtx. took it to the dealer and got it replaced. works fine ever since

  7. #7
    If you change that thing out yourself be careful loosening the cap bolts on the housing. They seize from dissimilar metals and water. They break and a new housing will be needed. Ya can't drill them out because they're stainless.

  8. #8
    PWC Addict Magnummmmmmmmmm's Avatar
    Join Date
    Jan 2014
    Location
    SML, VA
    Posts
    337
    +1
    47
    Quote Originally Posted by crueldude View Post
    If you change that thing out yourself be careful loosening the cap bolts on the housing. They seize from dissimilar metals and water. They break and a new housing will be needed. Ya can't drill them out because they're stainless.

    Thanks for the heads up! I'm gonna take her in tomorrow to my local dealer to get the keypad fixed. how do you like your TX?

  9. #9
    PWC Addict Magnummmmmmmmmm's Avatar
    Join Date
    Jan 2014
    Location
    SML, VA
    Posts
    337
    +1
    47
    Took it to the dealer today. They had the switch in stock and replaced it. All is working as expected now!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Shocking handling from 2013 RXT-x 260
    By Autosport in forum 4-Tec Performance
    Replies: 33
    Last Post: 08-25-2015, 05:11 PM
  2. 2013 RXT-X 260 Icontrol problem
    By Alan Terry in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 08-07-2014, 03:30 PM
  3. 2013 RXT-X 260 question
    By Alan Terry in forum 4-Tec Performance
    Replies: 17
    Last Post: 08-06-2014, 09:05 PM
  4. 2013 RXT-X 260 Installing 2011 and up Riva Speed Control Module
    By vidbuster in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-15-2013, 09:51 PM
  5. 2006 RXP with Stage II compared to 2013 RXT-X 260
    By vidbuster in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 02-06-2013, 02:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •