Results 1 to 5 of 5
  1. #1
    SuperCharged67's Avatar
    Join Date
    Jun 2012
    Location
    Halifax, NS, Canada
    Posts
    1,962
    +1
    76

    250x missing hose?

    Click image for larger version. 

Name:	uploadfromtaptalk1407613075212.jpg 
Views:	77 
Size:	28.3 KB 
ID:	338322Any idea if this is supposed to attach to anything? Its on top of the airbox


  2. #2
    the wotman likes boobs wotman's Avatar
    Join Date
    Mar 2009
    Location
    Australia
    Posts
    1,069
    +1
    48
    Quote Originally Posted by SuperCharged67 View Post
    Click image for larger version. 

Name:	uploadfromtaptalk1407613075212.jpg 
Views:	77 
Size:	28.3 KB 
ID:	338322Any idea if this is supposed to attach to anything? Its on top of the airbox
    looks like a diy fogging port.

  3. #3
    SuperCharged67's Avatar
    Join Date
    Jun 2012
    Location
    Halifax, NS, Canada
    Posts
    1,962
    +1
    76
    I read from riva instructions it was some valve cover hose would they put a DIY fogging port on the air box?

  4. #4
    the wotman likes boobs wotman's Avatar
    Join Date
    Mar 2009
    Location
    Australia
    Posts
    1,069
    +1
    48
    Quote Originally Posted by SuperCharged67 View Post
    I read from riva instructions it was some valve cover hose would they put a DIY fogging port on the air box?
    if thats it's purpose. Yes. If not and it has a hole in it, you can use it to fog the super charger.

  5. #5
    I have the exact same thing on mine. Did you find out what it is?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 250x missing and rough idle
    By jefski520 in forum Kawasaki How To & FAQs
    Replies: 4
    Last Post: 03-20-2016, 11:12 AM
  2. missing hose
    By tran_eng in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 12-11-2013, 05:15 PM
  3. Ultra 250 missing hose
    By MaineiacMoose in forum Kawasaki How To & FAQs
    Replies: 24
    Last Post: 07-19-2013, 05:48 PM
  4. 250X low speed miss morphs into now it won't run
    By reallybigboat in forum Kawasaki PWC Performance (4-stroke)
    Replies: 40
    Last Post: 02-12-2008, 03:13 PM
  5. Help - 250X Bogs/Missing
    By ghashimoto in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 02-10-2008, 06:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •