Results 1 to 3 of 3
  1. #1

    Exclamation Seadoo starts but won't go

    Hi I have a 2012 seadoo gti se 130. I was out on the lake and suddenly stopped. Heard some beeping, said module error and ski won't go forward or back. I shut off waited a while and restated but same issue. It starts fine. I can't depress throttle and it revs with minimal movement but nothing significant. It feels like it's stuck in neutral. I checked the intake and there was no debris there. Any advice? Thanks.

  2. #2
    Tiny's Avatar
    Join Date
    Sep 2006
    The Atl
    IBR issue???

    Bad wear ring???

  3. #3
    VENOM008's Avatar
    Join Date
    Jun 2014
    Miami Florida
    Check throttle cable not loose and does impeller spin strong out of the water when you flushed.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 98 zxi 1100 start button won't engage solenoid. HELP
    By Paulgibsonlgc in forum Kawasaki How To & FAQs
    Replies: 5
    Last Post: 08-22-2012, 04:04 PM
  2. '89 650sx starts but won't stay running, then backfires!!
    By eazygoin in forum Kawasaki PWC Performance (2-stroke)
    Replies: 5
    Last Post: 01-24-2012, 11:13 AM
  3. Help 1995 SeaDoo 650 GTX Won't Start
    By JohnCiccarelli in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 11-30-2011, 01:48 PM
  4. Flipped Seadoo, now it won't start.
    By dmg224 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 07-24-2011, 08:20 PM
  5. 2006 Seadoo GTI se won't start, HELP!
    By islandboystcroix in forum 4-Tec Performance
    Replies: 0
    Last Post: 06-17-2011, 06:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts