Results 1 to 2 of 2

Thread: Pto question

  1. #1
    B&V
    Join Date
    Jun 2007
    Location
    Lake Grove NY
    Posts
    158

    Pto question

    02 gp1200 riding waves,lost power ,engine revving,impeller not moving,pulled pump,ok but impeller can turn with engine off,shaft splines look fine ,measured shaft and spline ,same dia,pto blown??,can it be pulled with engine pulled foward ??


  2. #2

    Join Date
    Jul 2005
    Location
    Central North Carolina
    Posts
    3,847
    +1
    528
    Quote Originally Posted by b&v View Post
    02 gp1200 riding waves,lost power ,engine revving,impeller not moving,pulled pump,ok but impeller can turn with engine off,shaft splines look fine ,measured shaft and spline ,same dia,pto blown??,can it be pulled with engine pulled foward ??
    splines in pto shaft are worn out I supect. it can be removed if you move the engine foward. Tommy Jordan

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question about timing cover(pto cover)??
    By ModularJunk in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-31-2012, 07:48 AM
  2. 96 GTX Seized the PTO piston WHY is the big question ?
    By canuck in forum 2-Stroke Performance
    Replies: 15
    Last Post: 07-04-2011, 12:40 PM
  3. PTO Water / Oil Pump Shaft Installation Question
    By Craigo in forum 4-Tec Performance
    Replies: 5
    Last Post: 12-14-2010, 01:49 AM
  4. SL 700 rebuild after PTO burndown. Lots of pictures and questions
    By friscoboater in forum Polaris Open Discussion
    Replies: 14
    Last Post: 09-25-2010, 12:32 PM
  5. Help upgrading oiler in PTO and question on new X-charger?
    By awague2 in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-03-2010, 12:21 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •