Results 1 to 2 of 2
  1. #1

    Join Date
    Jan 2007
    Location
    Lake Powell, Page, Az
    Posts
    323

    05 Kawi STX15F PROBLEM

    Looking for a little help on a 15F. There is no power to the fuel pump. I have a donor ski , so I tried the main relay, tried a new fuel pump, tried switching the ecu, tried the rollover switch. The ski will fire on starting fluid. Any suggestions? thanks in advance...


  2. #2
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    4,485
    +1
    320
    Check the power at the plug that connects to the fuel pump can, if there is power there then verify that power is at the connector just inside the pump can. Also make sure to check that the fuel pump relay works.

    Sean

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB 05 kawi stx15F Prop
    By Kneedragger85 in forum Kawasaki Classifieds
    Replies: 1
    Last Post: 05-16-2016, 08:51 AM
  2. 05 3D Steering Problem
    By ba6636 in forum 2-Stroke Performance
    Replies: 0
    Last Post: 05-28-2008, 12:04 PM
  3. sea-doo 05 trim syst problems need help
    By daddyfranky in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 02-27-2008, 09:33 AM
  4. 05 RXP electrical problem
    By Roger H in forum 4-Tec Performance
    Replies: 1
    Last Post: 01-27-2008, 09:23 PM
  5. 05 RXP Starting problems
    By Cody Townsend in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 05-09-2006, 05:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •