Results 1 to 4 of 4
  1. #1

    Join Date
    Apr 2012
    Location
    Southern California
    Posts
    308

    Polaris virage txi

    I have a 2001 virage txi 1200 I just put a brand new crank on it and put it all back togethor and got 125 compression across the board I ran it on the hose for about 15 min and every thing looked and sounded great I took a compression test and the rear cylinder dropped to 60 and the others stayed the same I took off the head and everything looks perfect what could be the problem.


  2. #2

    Join Date
    Apr 2012
    Location
    Southern California
    Posts
    308
    i had also noticed that i could blow through the return line of the injectors, which isnt right the fuel restrictor in the tank is their any way to fix that instead of pulling the steering column and pull the fuel pump.

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,601
    +1
    1,277
    Low compression on one cylinder suggests the piston or rings were not installed correctly. Did you install new piston or new rings?

    The steering does not need to be removed on the Virage to get the Ficht fuel pump out. Steering removal is only needed for the MSX 140.

    15 minutes run time on the hose is excessive if the jet pump and driveshaft were installed.

  4. #4

    Join Date
    Apr 2012
    Location
    Southern California
    Posts
    308
    Quote Originally Posted by K447 View Post
    Low compression on one cylinder suggests the piston or rings were not installed correctly. Did you install new piston or new rings?

    The steering does not need to be removed on the Virage to get the Ficht fuel pump out. Steering removal is only needed for the MSX 140.

    15 minutes run time on the hose is excessive if the jet pump and driveshaft were installed.
    No the piston and cylinder are the original the crank was froze when I got I I will pull the cylinder and check the rings.

    Okay the fuel pump just looked so tucked in their I thought it would need the same thing as the msx 140

    The pump was not installed when I ran it on the hose.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How to Remove and repair Ficht fuel pump on 2002 polaris virage txi
    By john8873 in forum Polaris How To & FAQs
    Replies: 10
    Last Post: 07-26-2016, 11:36 AM
  2. 2002 Polaris Virage TXI
    By Dirtbiker2007 in forum Polaris Open Discussion
    Replies: 18
    Last Post: 07-18-2007, 04:53 AM
  3. 02 Polaris Virage TXI Burnt piston after 12 hrs?
    By svtfan in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 07-15-2007, 07:52 PM
  4. 2002 Polaris Virage TXi.. HELP!!! WON'T START
    By fitch615 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 06-05-2007, 04:31 PM
  5. 2001 Polaris VIRAGE TXI performance upgrades?
    By john8873 in forum Polaris PWC Performance
    Replies: 7
    Last Post: 03-08-2007, 06:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •