Results 1 to 2 of 2
  1. #1

    Post 1996 speedster runs great and dies

    1996 speedster with twin 720s runs great for 30 seconds then starboard motor dies. Has new fuel lines 150psi in each cylinder, new spark plugs. It is a considerable amount hotter than the port side motor. I have know idea what to do next, I've gone through the carb and adjusted accordingly. Any ideas??

  2. #2
    Pwgsx's Avatar
    Join Date
    Sep 2006
    DFW- Tx
    Are you sure the carbs are clean on the engine? Internal fuel filters and all? What do the plugs look like? If you are saying the engine is hotter then you are lacking water to cool the motor. I would start with your cooling issue and go from there. Check pump screen for clogs, remove the cooling line and see if you can blow thru it. Hook it up and try and flush the engine out- engine must be running!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. STX 12F Runs Rough and died when hot
    By TonyP70 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 2
    Last Post: 03-11-2013, 10:05 PM
  2. '01 virage 701 runs great then dies
    By jwick in forum Polaris How To & FAQs
    Replies: 0
    Last Post: 05-21-2012, 09:09 PM
  3. 02 XPL runs great and then starts to slow down, help!
    By 4ringturncoat in forum 2-Stroke Performance
    Replies: 2
    Last Post: 07-29-2008, 07:44 AM
  4. 800 sea-doo GTX runs and dies
    By wavebreaker in forum 2-Stroke Performance
    Replies: 7
    Last Post: 06-07-2008, 08:26 AM
  5. 1996 Speedster and wedges
    By Kragar in forum Sea Doo Sport Boats
    Replies: 2
    Last Post: 05-20-2008, 08:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts