Results 1 to 9 of 9

Thread: whats this ?

  1. #1

    Join Date
    Oct 2011
    Location
    Metairie louisiana
    Posts
    98

    whats this ?

    Click image for larger version. 

Name:	photo (1).jpg 
Views:	107 
Size:	95.1 KB 
ID:	338621 that my j pipe 2005 rxp did somebody weld an 02 sensor bung there previously or is that factory


  2. #2
    SELF27's Avatar
    Join Date
    May 2013
    Location
    Austin, TX
    Posts
    202
    +1
    16
    not factory, that is a o2 bung

  3. +1 by:


  4. #3
    baba850r's Avatar
    Join Date
    Sep 2007
    Location
    scotland
    Posts
    673
    +1
    4
    Yep def not factory.Handy if ur for logging all the same.

  5. #4

    Join Date
    Oct 2011
    Location
    Metairie louisiana
    Posts
    98
    Is that a good location for it ? Every time I work on this thing I find something else from the previous owner

  6. #5
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    475
    that spot is ok...the only other spot is in the manifold and some have had water leaks there too

  7. #6
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,179
    +1
    97
    What do the 3 wires go to? the 2 browns and the black?
    Also, looks like your superchager intake hose clamp is missing.
    Supercharger is not stock either, has a spacer in it

  8. #7
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Those are bilge pump wires.

    Looks like your gonna have a fun time trying to remove that bung..... if you ever attempt to do so! The bung mount, plug, and welding wire all appear to be carbon steel.

  9. #8
    GGG's Avatar
    Join Date
    Sep 2009
    Location
    Jersey Shore
    Posts
    2,830
    +1
    258
    I don't like the looks of that hose clamp either. Not stainless. Look for more rusty clamps before you sink

  10. #9

    Join Date
    Oct 2011
    Location
    Metairie louisiana
    Posts
    98
    That's litteraly the only clamp on the rig that isn't stainless steel I've have the motor out a few times most recent from letting some one else ride and they wrecked it but I've never really notices the buns before just thought it was suposed to be there. I've had the ski for three years so you know it had to be on since then

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. whats this handle for
    By shrttkid935 in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 04-11-2007, 01:57 AM
  2. Guess what this device is....
    By Hydrotoys in forum Open Discussion
    Replies: 10
    Last Post: 02-12-2007, 02:16 PM
  3. I would rather own a seadoo than do what this guy did.
    By QuickMick in forum Open Discussion
    Replies: 8
    Last Post: 05-31-2006, 01:57 PM
  4. Anyboyd know what this is for?
    By Green Hulk in forum 4-Tec Performance
    Replies: 21
    Last Post: 10-25-2005, 11:24 AM
  5. Anyone have this problem or knkow what this means.
    By Therock in forum 4-Tec Performance
    Replies: 21
    Last Post: 08-22-2005, 08:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •