Results 1 to 4 of 4

Thread: 2007 RXP

  1. #1

    Join Date
    Jun 2007
    Location
    Bolton Landing, NY - Howard Beach, NY
    Posts
    44

    2007 RXP

    Hello,

    I have a 2007 RXP, only getting low 60s at around 7700rpm, both machines have metal washers. I havent changed anything on the machines besides two new engines when the orginal washers went. Do you think its the impeller?

    Thank You


  2. #2
    Michigan sn-95's Avatar
    Join Date
    Sep 2010
    Location
    Hamilton MI
    Posts
    734
    +1
    32
    Quote Originally Posted by JC7727 View Post
    I havent changed anything on the machines besides two new engines when the orginal washers went. Do you think its the impeller?

    Thank You

  3. #3
    Spray soapy water, make shore she's has no leaks and the intercooler is clean, I just went through the same rpm and speeds.

  4. #4

    Join Date
    Feb 2012
    Posts
    663
    +1
    45
    Check wear ring and impeller.
    Make sure IC isn't leaking at all
    whats slip at on the Sc?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Who put the most hours on their 2007 RXP/RXT
    By H2HO in forum Sea Doo Open Discussion
    Replies: 15
    Last Post: 03-07-2010, 08:25 PM
  2. 2007 RXP
    By burnout in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 06-29-2007, 08:34 PM
  3. 2007 RXP Problem! Please Help
    By Ericc in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-11-2007, 10:33 AM
  4. See this 2007 RXP accident ...... WOW
    By qatar2000kk in forum 4-Tec Performance
    Replies: 51
    Last Post: 06-08-2007, 07:11 AM
  5. 2007 RXP Questions
    By TroyRXP15 in forum 4-Tec Performance
    Replies: 15
    Last Post: 09-22-2006, 02:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •