Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    Please help with my rxt x 255 2008 cavitation problem

    I have a rxt x 255 2008 with some modes.

    Torxs ecu 10000 rpm
    riva retainer kit
    14/19r riva
    large intercoller
    stock supercharger
    fuel presure regulator
    afr 11.5
    r&d intake greate
    cut oem plate
    new carbon
    new plate
    new below


  2. #2
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    6,378
    +1
    981
    Check driveshaft fore/aft movement and engine alignment. The engine may be positioned too far forward. Check for 1/4" forward/rearward movement of the driveshaft. If more than 1/4", move the engine rearward. Align the engine/driveshaft so the hat sits squarely/centered on the carbon seal.

  3. #3
    Thanks for the advise but the shaft is dead center.please another tip

  4. #4
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Quote Originally Posted by jccycle View Post
    I have a rxt x 255 2008 with some modes.

    Torxs ecu 10000 rpm
    riva retainer kit
    14/19r riva
    large intercoller
    stock supercharger
    fuel presure regulator
    afr 11.5
    r&d intake greate
    cut oem plate
    new carbon
    new plate
    new below
    Stock SCer with a 10K ecu. With the 10K map should be running a big SCer it doesn't have a bunch of timing up top. Whats the prop depitched to? Whats are your rpms? 4 blade or 3 blade prop? You should be running a 15/20 SOLAS anyway. What exit nozzle are you running? Should be using an 83mm exit nozzle.

    Its just about impossible to get holeshot with an R&D grate and an 87mm nozzle with a 4-blade SOLAS prop. The R&D blocks off too much intake.

  5. #5
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    6,378
    +1
    981
    Quote Originally Posted by jccycle View Post
    Thanks for the advise but the shaft is dead center.please another tip
    Engine may be too far forward. Check fore/aft movement of driveshaft. The driveshaft can appear to be centered, but is the HAT squarely centered on the carbon seal?

  6. #6
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Quote Originally Posted by 1tommygunner1927 View Post
    Quote Originally Posted by jccycle View Post
    Thanks for the advise but the shaft is dead center.please another tip
    Engine may be too far forward. Check fore/aft movement of driveshaft. The driveshaft can appear to be centered, but is the HAT squarely centered on the carbon seal?
    He should check all that stuff, but his set up is not complete or its screwed up.

  7. #7
    Jp thanks for the info .what intake grate you recomend. I have the stock one

  8. #8
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    6,378
    +1
    981
    Quote Originally Posted by jp1300r View Post
    Quote Originally Posted by 1tommygunner1927 View Post
    Quote Originally Posted by jccycle View Post
    Thanks for the advise but the shaft is dead center.please another tip
    Engine may be too far forward. Check fore/aft movement of driveshaft. The driveshaft can appear to be centered, but is the HAT squarely centered on the carbon seal?
    He should check all that stuff, but his set up is not complete or its screwed up.
    Yup.....

  9. #9
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Quote Originally Posted by jccycle View Post
    Jp thanks for the info .what intake grate you recomend. I have the stock one
    The R&D will work and give the best speed. Run an 83mm stock RXT/RXP exit nozzle, and SOLAS 15/20 pitched by Duke. Make sure pump seal, pump bearings, prop, wear ring are perfect. Will always will get a 2-3 cavitation type spins, but ok in my book. Over that you need to start looking for something to tweak or fix.

  10. #10
    Thanks for the help i checked the shaft and was to the side. I centered and problem solve. Good holeshot and 78.5mph

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need some likes on facebook! please help with my other hobby!!
    By Bondar in forum Sea Doo Open Discussion
    Replies: 18
    Last Post: 11-30-2013, 09:37 AM
  2. Please help with my 02 GTI problem
    By TBirdEd76 in forum 2-Stroke Performance
    Replies: 7
    Last Post: 12-03-2011, 04:40 AM
  3. Please help with my 2002 Polaris Virage TXi check engine code
    By Dan416 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 08-25-2011, 05:08 PM
  4. need some help with my rxt
    By johnrxp in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-29-2011, 08:52 AM
  5. Need help with my conversion from a 2008-9 rxp
    By Hydrotoys in forum 4-Tec Performance
    Replies: 6
    Last Post: 01-31-2009, 08:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •