Results 1 to 2 of 2
  1. #1

    Join Date
    Jul 2013
    Location
    Missouri
    Posts
    5

    97 xp no start no beep

    I'm working on a 97 seadoo xp. When I plug in the dess gauges come on but I get nothing when I hit start button and I'm not getting the usual 2 beeps when I plug the key up. Now I I pulled the start stop switch out to get access to it and if I ground the black wire and press button I get nothing, but if I just ground yellow red wire it start cranking. I just want someone to confirm that it is a bad start stop switch by that or if I need to do some other checks first? Thanks
    Last edited by connellykyle; 08-15-2014 at 04:14 PM.


  2. #2
    xxx2's Avatar
    Join Date
    Oct 2006
    Location
    panama city bch, Fl
    Posts
    421
    +1
    35
    If you don't know the history of the ski the beeper May not worked in the first place, the fact you can start the ski (and kill it?) With dess key tells me it's the switch. I would still test the switch with a volt meter

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97 GTI no beeps but still starts and runs perfectly
    By policano in forum 2-Stroke Performance
    Replies: 3
    Last Post: 06-24-2012, 05:56 AM
  2. '96 XP No beeps, but starts, now just cranks
    By jamesbern in forum 2-Stroke Performance
    Replies: 5
    Last Post: 04-18-2012, 07:19 PM
  3. 97 XP No Beep or start
    By jetskiperf1 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-02-2010, 10:49 AM
  4. 97 xp no intake grate/beeper
    By diesel04 in forum 2-Stroke Performance
    Replies: 1
    Last Post: 06-20-2009, 12:47 AM
  5. 97 XP No Start
    By tccmi in forum 2-Stroke Performance
    Replies: 6
    Last Post: 09-01-2008, 05:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •