Results 1 to 2 of 2
  1. #1

    gtx155 electrical question

    I just wanted to say thanks for taking the time out to read my post....I haven't posted on here in a while but I do frequently browse the forums.

    I'm looking a purchasing a 2003 gtx 155 this machine is literally a basket case it dropped a valve know the story .

    long story short, the seller was asked the hours on the machine the engine was pulled with the intake left in the hull hooked up ( ecm, mpem, injectors,..ect) what he did was throw the battery in and hook the 3 engine grounds back to the ground on the battery and hooked up the dess "apparently" the fuel pump came on but the cluster did not light. I told him to check the fuse and I guess they are all good.

    is there any reason why this would not work ..? and is there anything that I can check when I go look at this machine I don't want to get into something that's going to be a money pit sort of speak

  2. #2
    Anyone have any idea ...? I'm looking at driving 4 hours tomorrow night to pick this machine up

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Will this work, electrical question
    By bruinsrme in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-04-2008, 11:17 AM
  2. Domestic Electrical Question
    By Justme in forum Polaris Open Discussion
    Replies: 7
    Last Post: 04-09-2008, 07:42 PM
  3. electrical question
    By bacongrease in forum 2-Stroke Performance
    Replies: 1
    Last Post: 08-03-2007, 05:12 PM
  4. 95 spx electrical question
    By 95 sl750 in forum 2-Stroke Performance
    Replies: 3
    Last Post: 04-17-2007, 08:51 PM
  5. Electrical question
    By absentx in forum Polaris Open Discussion
    Replies: 2
    Last Post: 03-30-2007, 08:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts