Page 1 of 13 1 2 3 11 ... LastLast
Results 1 to 10 of 122
  1. #1

    Turbo RXTX 260 RS Bogging problem maybe from wastegate?

    Hey guys, im kinda finding out the problem to my ski, briefly, im running a RXTX 260 RS Turbo at what i think is boost which i myself isnt sure. My dad built this ski for over 3 years? and got it perfect before he passed away almost a year ago falling off the ski at the home straight and fracturing his c6 vertabrae around his neck and eventually moving on. so being along side him through out the years i learnt a few basic things like reflashing motec and looking at knock levels and engine temps but im not so experienced with the map parameters and with the turbo equipment like the wastegates and boost control. im only 17 so please be nice Can i possibly get someone to help me with the maps and some basic motec knowledge? im very keen to learn
    And moving on to the problem. im running full blast down the straight and i let off the gas and begin to turn, and when im trying to launch out, the ski bogs or holds itself down below 4000rpm for about 2-4 seconds before getting itself back up and flying off as usual.This normally happens if i completely go from 100% to 20%ish throttle pos. to slow down approaching a turn, when taking a 90 or more degree turn or more and i dont let off too much for too long, i perform the turn perfectly without any delays or bogging.
    HELPPPP

    Video of what im going through

    http://www.proridermag.com/in-memory...uan-1963-2013/

    Thanks Guys!!!!!!
    Last edited by TanTeckSang; 08-20-2014 at 01:17 AM. Reason: TYPOSSS


  2. #2
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    Welcome to the GH

    yes, the blow off valve could be sticking
    take it off inspect clean and lube it

    tell us about your ski
    post a screen shot of your log like this
    Click image for larger version. 

Name:	ptsc.png 
Views:	123 
Size:	172.4 KB 
ID:	339065
    Last edited by skidoochris; 08-17-2014 at 09:02 AM.

  3. #3
    SLASHER's Avatar
    Join Date
    Jun 2007
    Location
    Australia, Perth WA
    Posts
    3,263
    +1
    474
    Sorry to hear about ur dad ....

    Check the basics i.e plug fouling under load or crappy old fuel ...

  4. #4
    The most interesting man in the world. Nils888's Avatar
    Join Date
    Jun 2005
    Location
    California
    Posts
    4,231
    +1
    1,043
    Can you get a Data log file out of the ECU. I would be happy take a look at it. Are you using the ECU to control boost?

    It sounds like there might be some Antilag setup that is not quit rite.

  5. #5
    2010 rxpx 260 and the visual setup is almost similar to your avatar picture but the turbo is further to the side and the turbo is barely popping out from the sides. custom exhaust cooling, turbosmart boost controllers and wastegates, knock control, boost control, anti lag, not sure about the prop pitch or the amount of blades on it. not much i can point out. any advice on how to remove the wastegate? is it very simple? or can i just spray some lube like WD40 from the outside? can it be just the shaft to the wastegate? do i have to remove the turbo?

  6. #6
    yeap. PM-ed

  7. #7
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    I must me still half a sleep because I said waist gate and I should have said blow off valve....

  8. #8
    The most interesting man in the world. Nils888's Avatar
    Join Date
    Jun 2005
    Location
    California
    Posts
    4,231
    +1
    1,043
    Quote Originally Posted by skidoochris View Post
    I must me still half a sleep because I said waist gate and I should have said blow off valve....
    Wake UP!!!

  9. +1 by:


  10. #9
    Here ya go !!!!!!Click image for larger version. 

Name:	blabla.PNG 
Views:	156 
Size:	104.0 KB 
ID:	339068 but my blow off valve sounds fine

  11. #10
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    Nilis will sort out any motec problem

    also motec has a lots of youtube info videos "webinar"


    that's nice for a start but he needs the whole file

  12. +1 by:


Page 1 of 13 1 2 3 11 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2011 RXT X 260 RS Mechanical Problems
    By Harrison2303 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 05-31-2016, 05:57 AM
  2. 2011 Rxtx 260 RS
    By mad dog in forum Australia
    Replies: 0
    Last Post: 01-02-2014, 03:44 AM
  3. RXTX 260 rs 2010 pump issue
    By RT260RS in forum 4-Tec Performance
    Replies: 5
    Last Post: 01-06-2012, 06:24 PM
  4. Rxtx 260 rs SPONSON
    By danieletrono in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-25-2010, 05:13 AM
  5. Rxt-x 260 rs mrg turbo setup
    By JESUS G in forum 4-Tec Performance
    Replies: 10
    Last Post: 07-05-2010, 10:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •